So slow in loading the log files via stdin plugin


(Andy Park) #1

Hi guys,

Currently I need to load some logfiles contained in tar (archive) files. To load them into filebeat, I am using gzcat tool to echo the log files inside the archive files using stdin input for filebeat. For a 200mb log file, it takes more than 1 hour. We wonder if there would be any way to speed things up. I was playing with different buffer size and poolsize options but it did not help much. Also, I tried using an SSD drive instead of a regular hard drive but it did not help much either. Any help would be greatly appreciated.

Thanks,
Andy


(ruflin) #2

Could you share your setup, version of filebeat, config file and the log file? 1h for 200mb sounds way too long.


(Steffen Siering) #3

Which output are you using?


(Andy Park) #4

filebeat.prospectors:

  • input_type: stdin
    document_type: log

    multiline.pattern: ^[
    multiline.negate: true
    multiline.match: before

filebeat.spool_size: 8192
filebeat.publish_async: true

output.elasticsearch:
hosts: ["localhost:9200"]
template.enabled: false

template.path: "/etc/filebeat/filebeat.template.json"

output.logstash:
hosts: ["localhost:5044"]
bulk_max_size : 2048
loadbalance: true
workers: 4


(Steffen Siering) #5

you're outputting to ES and LS at the same time. One/both might generate back-pressure, slowing down filebeat.


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.