SQS client ignores the fips flag for the service endpoint

At least in 7.15.1 when using the fips_enabled flag, only s3 respects the fips configuration. SQS does not. It seems to be hard coded. beats/input.go at master · elastic/beats · GitHub

That's a good point. I'd submit a GitHub issue as there are other AWS services that might need to be updated to accommodate fips besides S3 and sqs.

@Kaiyan_Sheng could we just move the fips_enabled setting to the AWS common module?

1 Like

Yes good point! Let's move this config into libbeat aws common. Thank you!!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.