SSL doesn't work when sending data from Winlogbeat to Logstash

(Eli Cohen) #1

Hello,
I've configured my Logstash server to accept SSL and my Winlogbeat configuration as well.

Logstash configuration:

input {
beats {
port => 5044
client_inactivity_timeout => 0
ssl = > true
ssl_certificate => /etc/logstash/server.logstash.crt
ssl_key => /etc/logstash/server.logstash.key
}
}

Winlogbeat configuration:

output.logstash:

hosts: ["server:5044"]

compression_level: 3

ssl.enabled: true

ssl.certificate_authorities: ["C:\Program Files\Winlogbeat\server.logstash.crt"]

SSL worked for me using this configuration before... But a few days later, it stopped working. I can't figure out my problem.

I thought that maybe the problem is with the certificate, but it did work before... And I can't change the certificate that easily.

Thanks a lot!

(system) closed #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.