Start-Service heartbeat fails

I have used your file heartbeat.yml and restarted the service.

In "Discover", I get :

Time                            http.request.method   http.response.status_code
Jan 25, 2023 @ 16:51:48.000     GET                   200
Jan 25, 2023 @ 16:51:28.000     GET                   200

That seems good !

I am surprised that It was not necessary to enable some modules, like in metricbeat where I enabled the modules system and sql...

Is this file "http_dashboard.ndjson" still usefull ?

In C:\Program Files\heartbeat\kibana\7? No need

If you are using standard index, not customized, you should see data in Kibana Dashboards
http_dashboard.ndjson is only to import the dashboard in Kibana

Do you have a visual? Mobile One, can you copy, please? :grinning:

OK, I suppressed this file.
I my main dashboard, I use the index = "xconf-qa-*" (like configured in the beats/modules)
In Kibana, I found the dashboard "Heartbeat HTTP monitoring", but it uses "heartbeat-*", then this dashboard doesn't work here. (No matching indices found: No indices match pattern "heartbeat-*")

I made a simple visualisation with axes :
- horizontal : @timestamp
- vertical : http.response.status_code
export (1)
(I used a wrong address in the file heartbeat.yml to get some "400")
I don't know if this is this visual that you wanted.
This seems to be a good starting point to get a nice graph.

You have option:

  1. Use heartbeat index:
output.elasticsearch:
  hosts: ["edaa...nt.com:9243"]
  protocol: "https"
  username: "xconf-qa-write" # this username must have rights on heartbeat-* index.
  password: "pass"
  ssl.verification_mode: none
  #index: "xconf-qa-%{[agent.version]}-%{+yyyy.MM.dd}"

No need changes on the dashboard "Heartbeat HTTP monitoring"
or
2. Change the data view to show data from Index pattern: xconf-qa-*
or
3. Edit http_dashboard.ndjson and replace index pattern refence with your xconf-qa-* and import the dashboard again
"references":[{"id":"heartbeat-*","name":"kibanaSavedObjectMeta.searchSourceJSON.index","type":"index-pattern"},{"id":"heartbeat-*","name":"kibanaSavedObjectMeta.searchSourceJSON.filter[0].meta.index","type":"index-pattern"}]



Hi Rios, thank you for your 3 options.

  1. I prefer not to have several indexes to manage.
  2. I would have liked this, but I couldn't find "Dataview" in "Stack management", nor elsewhere (pb of version ? I use 7.16.7, pb of rights ?)
  3. In the file "http_dashboard.ndjson" I replaced "heartbeat-" with "xconf-qa-" twice (in the part of text you showed)

This is OK !!!

I open the dashboard "Heartbeat HTTP monitoring" , and there are no more errors, and the graphs are displaying.
There is just a message " There are too many series defined (56). The configured maximum is 50." but it only concerns the panel " HTTP duration heatmap" that I don't think it will be useful to me.

Thanks a lot!

1 Like

Data view on 8.x is Index patterns on 7.x.

There are too many series defined.

Already mentioned on other topic: Stack management > Advanced settings , then look for visualization:heatmap:maxBuckets

Thanks Rios.
I now have the issue of testing multiple urls and I will open a new topic.