Metricbeat Service can't Start Running

Hello, im in a project that need to install kibana-elasticsearch-metricbeat now i already install all of that, but after i install metricbeat and configure the yml file i cant start the metricbeat serive.

This is my PowerShell command :
PS C:\Program Files\Metricbeat> Start-Service metricbeat

And this is the error i got:

> Start-Service : Service 'metricbeat (metricbeat)' cannot be started due to the following error: cannotstart service metricbeaton computer'.'.
> At line:1 char:1
> +Start-Service metricbeat
> + -----------------------
>       + CategoryInfo : OpenError: (System.ServiceProcess.ServiceController:ServiceController) [Start-Service], ServiceCommandException
> 	  + FullyQualifiedErrorId : CouldNotStartService,Microsoft.PowerShell.Commands.StartServiceCommand

What should i do to resolve this one?

i also tried to run this script:

PS C:\Program Files\Metricbeat> .\metricbeat.exe -c metricbeat.yml -e -v -d "*"

but i got long error message only

Please help me to run the metricbeat service on my windows

1 Like

Can you please post your metricbeat yaml file?

Maybe someone can help you with the powershell command but while so, can you paste the output of the second command? the metricbeat.exe -e -d "*". Also, as @tristan1 says, the configuration is useful to understand which services are you trying to monitor

thankyou for your concern, the problem already solved by running .\metricbeat.exe setup --dashboards before i run Start-Service metricbeat :blush:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.