Stuck in Logstash

Whenever I am running file, it is stuck even I tried different file but still stuck.

It is not stuck, it is running, the line Successfully started Logstash API endpoint means that logstash is up and running.

What is your pipeline configuration, what you are trying to do and what is the expected result?

It should shows the values that have inside my file.

Share your conf file in formatted text.

Most likely it already read the file, which it will only do once....ever unless you clean up the sincedb or set the sincedb path to "NUL" for windows.

sincedb_path => "NUL"

Or it can't find a file to read.

It should show this output. I already defined sincedb_path null in config file.

You need to share your config using the formatted text option (the <\> button), without seeing your pipeline config there is no way to understand what you are trying to do and what the problem is.

Yes please show your config.

BTW it is not null on windows it is very specifically "NUL" 1 L

Exactly as I showed it, caps everything.

Here is my config file;
sincedb_path => "NULL", I have used always but not get any error message.


path => "C:/Users/Ubaid/Desktop/SampleNBP.csv"
start_position => "beginning"
sincedb_path => "NULL"

separator => ","
columns => ["Date","Mobile","Telco","Msg","ShortCode","SMSLength","DeliveryDate","DeliveryStatus","Criteria"]

elasticsearch {
hosts => "http://localhost:9200"
index => "sampledata"

I have also tried codec=> rubydebug

I'm not sure why you're not getting an error it's just not working for you so I'm unclear why you would not try the actual correct syntax.

What I provided is the correct syntax . NUL not NULL

If you fix that and then it still doesn't work we'll look at some other items

I am working since two months and always using NULL not NUL.

Great, so you have been persisting the in-memory sincedb to a file called NULL across restarts. When logstash starts it reads the file called NULL (probably from the current-working-directory) and populates the sincedb. If you write it to a file called NUL instead then the writes are discarded and the in-memory sincedb starts off empty.

If you use NULL you will not get an error, logstash will work with it just fine. It just will not do what you want.

1 Like

Thanks @Badger I was thinking that ^ was the case but didn't have a windows to test on. Now I have that in my tool / answer chest!

Sir I updated the file with NUL but Still not getting anything on the console.
it is stuck there successfully started logstash API endpoint:

Enable --log.level trace. Direct the logs to a file, because there will be a lot of them. Once logstash has logged the "Successfully started Logstash API" message, wait 60 seconds. Then search the logfile for messages from the filewatch module. See here for an example. If you cannot understand the logs, post the messages from filewatch (not everything) either here, if possible, or on or another file sharing site.

Thank you so much Dear @Badger for your patience. I will follow your steps.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.