Systemctl start filebeat does not start filebeat

after changing some configuration
(I added
json.message_key: message
json.keys_under_root: true
and doing restart to filebeat, filebeat refuses to start
with nothing showing on the logs...

Problem was solved (somehow it just started after about an half an hour of retries)

When changing config it is useful to run the config test with: -e -configtest

And when dealing with failures you can run Filebeat in the foreground to see all log output: -e -d "*"

(-d "*" enables debug logging)

1 Like

Thanks @andrewkroh, this will help me in future configuration!

By any chance do you know if logstash has a feature such as: -e -configtest (I tried -e -configtest but with no success)

I think the equivalent for LS is

/usr/share/logstash/bin/logstash --configtest -f <config file or dir>

1 Like

Note that starting with Logstash 5.0, the --configtest option was renamed to --config.test_and_exit. So the command for testing the config file with version 5.0 and later would look something like this:

path/to/bin/logstash -f configfile --config.test_and_exit


1 Like

This topic was automatically closed after 21 days. New replies are no longer allowed.