The client_location doesn't appear in the output fieds


(Chen Augustin) #1

Hi,
My http protocols look like the following. It appears the client_location never appears in the output fields. Is there is somehting wrong in my configuration?

protocols:
http:

# Configure the ports where to listen for HTTP traffic. You can disable
# the http protocol by commenting the list of ports.
ports: [80, 8080]
real_ip_header: "X-Forwarded-For"
send_request: true
send_response: true

(Tudor Golubenco) #2

You need a GeoIP database installed. See this Github thread for a way to download it that is known to work: https://github.com/elastic/packetbeat/issues/60#issuecomment-132869921


(system) #3