This driver is not configured for integrated authentication


(Sourav Saha) #1

I am trying to connect SQL SERVER in window authentication mode from logstash and my connection string is given below:
input {
jdbc {
jdbc_driver_class => "com.microsoft.sqlserver.jdbc.SQLServerDriver"
jdbc_driver_library => "\pipeline\ISMS\sqljdbc_6.2\enu\jdbc-6.2.2.jar"
jdbc_connection_string => "jdbc:sqlserver://PMICHLAUSQL44\MSS2012;databaseName=Poland_PRD_MD;integratedSecurity=true"
jdbc_user => "
"
# jdbc_password => "
***"
statement_filepath => "*****\DateWiseHHDownloadDetails.txt"
tags => ["DOWNLOAD"]
}
}

But after execution of logstash.conf file I have got a error message which is :
[2018-06-14T13:04:28,441][ERROR][logstash.inputs.jdbc ] Unable to connect to database. Tried 1 times {:error_message=>"Java::ComMicrosoftSqlserverJdbc::SQLServerException: This driver is not configured for integrated authentication. ClientConnectionId:679f6e20-67f8-4d7c-bf46-ef30ec0edaaf"}

Need a solution regarding this issue.


(Ry Biesemeyer) #2

Is the machine on which Logstash is running also Windows, or is it Linux? I'm seeing a support article on MSDN about needing to specify authenticationScheme=JavaKerberos when connecting from a non-Windows host: https://blogs.msdn.microsoft.com/psssql/2015/01/09/jdbc-this-driver-is-not-configured-for-integrated-authentication/


(Ry Biesemeyer) #3

If running on Windows, this article seems to indicate that the problem can also occur if the sqljdbc_auth.dll is not on the JVM library path, which I believe to be more likely.

JVM Options can be set using the ${LS_HOME}/config/jvm.options file, as documented here


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.