Tomcat application server -- agent status show --No data has been received from agents yet

If you are asking about a problem you are experiencing, please use the following template, as it will help us help you. If you have a different problem, please delete all of this text :slight_smile:

Kibana version:
7.3.1

Elasticsearch version:
7.3.1
APM Server version:
7.3.1
APM Agent language and version:
elastic-apm-agent-1.9.0.jar
Browser version:
Firefox version 69
Original install method (e.g. download page, yum, deb, from source, etc.) and version:
deb
Fresh install or upgraded from other version?
Fresh install
Is there anything special in your setup?
Simple setup, I need to see how I can monitor tomcat application server using APM
My elasticsearch server, kibana, apm server works fine, did the necessary changes in catalina.sh
CATALINA_OPTS="$JPDA_OPTS $CATALINA_OPTS"
export CATALINA_OPTS="$CATALINA_OPTS -javaagent:/home/itsupport/elastic-apm-agent-1.9.0.jar"
export CATALINA_OPTS="$CATALINA_OPTS -Delastic.apm.service_name=my-tomcat"
export CATALINA_OPTS="$CATALINA_OPTS -Delastic.apm.application_packages=org.example,org.another.example"
export CATALINA_OPTS="$CATALINA_OPTS -Delastic.apm.server_urls=http://localhost:8200"

I have kept the "elastic-apm-agent-1.9.0.jar" , in the correct location as specified
My Issue
my APM client not connecting to the APM server, or I am not aware on which logs to check for APM client .
On the kibana server I am getting message
No data has been received from agents yet, while checking for agent status

Request guidance on trouble shooting the apm client part for tomcat,
Thanks
Joseph John

Hi Joseph,

If you are not seeing anything in your application logs, your script configurations are probably not applied. Validate your startup routine.

BTW, using -Delastic.apm.application_packages=org.example,org.another.example is wrong, unless your application packages are indeed org.example and org.another.example...

Good luck,
Eyal.

Thanks Eyal
You are right, my script configuration are not applied, I tried the same with JBoss in another instance and I am getting status back at Kibana.
So I have not done the correct settings for tomcat
About

-Delastic.apm.application_packages=

I will get rectify it and update in the forum
Thanks
Joseph John

Thanks a lot Eyal

JAVA_OPTS="$JAVA_OPTS -Delastic.apm.application_packages=org.compiere,org.adempiere"

this worked, I am getting data to the APM
thanks a lot.

1 Like