Tracking_column not found in dataset


(sami) #1

what does this error means? my lostash load is continuing but keep getting this intermittent messages .
I checked the tracking column "TXN_PROCESS_DATE" for nulls but it doesn't have any null values and its of date type.

[2017-08-31T15:50:00,046][INFO ][logstash.inputs.jdbc ] (0.009000s) SELECT TXN_ID,TXN_PROCESS_DATE,TRANSP_ID,TRANSP_CLASS,EXT_PLAZA_ID,EXT_LANE_ID,EXT_LANE_TYPE_CODE,EXT_DATE_TIME,TRANSP_CUR_BAL,AVC_CLASS,TOLL_AMT_CHARGED,TOLL_AMT_COLLECTED,TOLL_AMT_FULL,CREDIT_LIST_UPDATE_FLAG,TRANS_SOURCE,REVCLASS_REV_CLASS_CODE,PAYMENT_METHOD_CODE,ENT_PLAZA_ID,ENT_DATE_TIME,ENT_LANE_ID,ENT_LANE_TYPE_CODE,AGENCY_REJECT_CODE,MSG_ID,TRANSP_INTERNAL_NUM,UFM_PAYMENT_CODE,VEH_LIC_NUM,STATE_ID_CODE,ORIG_TXN_ID from TAB1 WHERE TXN_PROCESS_DATE >TIMESTAMP '2017-08-20 08:29:00.000000 +00:00'
[2017-08-31T15:50:00,047][WARN ][logstash.inputs.jdbc ] tracking_column not found in dataset. {:tracking_column=>"TXN_PROCESS_DATE"}


(Guy Boertje) #2

To be honest, I don't know.

I have checked the code and modified some tests to see if I can simulate it.

Some common issues:

  • Query is not sorted ascending on the tracking_column value.
  • The column name is changed to lowercase by the SQL library we use but the UPPERCASE column name is used in the tracking column setting.

(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.


(Jay Greenberg) #4

Also make sure you select the tracking column in the SQL statement. For example, if you do not have select *, then if you have:

tracking_column => "TXN_PROCESS_DATE"

Make sure you also do

select TXN_PROCESS_DATE, OTHER_COLUMN, ETC from ...