Trouble with using Logstash for the first time


(Günter Hipler) #1

Hi
I'm trying to use Logstash for the first time and I'm following the Docs in https://www.elastic.co/guide/en/logstash/2.1/first-event.html
After installing the latest 2.2 release (on Ubuntu 14.04 with Java >= 1.8.0_65 I use the command
bin/logstash -e 'input { stdin { } } output { stdout {} }'

to run a first test. I get the following exceptions
LoadError: load error: jopenssl/load -- java.lang.VerifyError: class org.bouncycastle.asn1.ASN1Primitive overrides final method equals.(Ljava/lang/Object;)Z
require at org/jruby/RubyKernel.java:1040
(root) at /home/swissbib/Downloads/logstash/vendor/bundle/jruby/1.9/gems/jruby-openssl-0.9.13-java/lib/openssl.rb:1
require at org/jruby/RubyKernel.java:1040
(root) at /home/swissbib/Downloads/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.2.0-java/lib/logstash/patches/stronger_openssl_defaults.rb:1
require at org/jruby/RubyKernel.java:1040
(root) at /home/swissbib/Downloads/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.2.0-java/lib/logstash/patches/stronger_openssl_defaults.rb:2
require at org/jruby/RubyKernel.java:1040
(root) at /home/swissbib/Downloads/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.2.0-java/lib/logstash/patches.rb:1
require at org/jruby/RubyKernel.java:1040
(root) at /home/swissbib/Downloads/logstash/vendor/bundle/jruby/1.9/gems/logstash-core-2.2.0-java/lib/logstash/patches.rb:5
require at org/jruby/RubyKernel.java:1040
(root) at /home/swissbib/Downloads/logstash/lib/bootstrap/environment.rb:66

Same happens with using a simple configuration file as documented in https://www.elastic.co/guide/en/logstash/2.1/advanced-pipeline.html

Any ideas what's going wrong?

Thanks for any hint

Günter


(Günter Hipler) #2

I solved the problem by myself. The CLASSPATH variable on my used laptops running on Ubuntu 14.04 referenced a customer jar with additional external jars where a not compatible version of class org.bouncycastle.asn1.ASN1Primitive is used. Unfortunately this was the case on two different devices I used for my first test case with Logstash.

Removing the jar in question from the classpath solved the problem.

While I needed some time to get the trick I saw a lot of other people describing nearly the similar problem. Maybe it would help if you include a note in your documentation.

The exception was thrown when I made my first steps with the tar version of Logstash (running my user shell) and of course didn't appear when I installed the deb package version. But for a newbie on the field of Logstash it's not obvious what might be the problem because I followed the documented steps to be done when Logstash is installed with the tar file.

Günter


(system) #3