Trying to follow Logstash tutorial

On centos 7, I've installed logstash, and beats via the repo mentioned in the docs. The very first test at "" works.

Now I'm trying "" Beats and Logstash start (i think) without error. Port 5044 is listening. Yet I don't see any of the log records echoed to stdout in the console where logstash is running.

What am I doing wrong? How to debug?

Alright. Basically the tutorial skips settings you need!

In the filebeat.yml file, filebeat.inputs section, change

enable: false


enabled: true

Comment out


Comment out

hosts: ["localhost:9200"]"

in output.elasticsearch section.

Make sure "output.logstash:" is not commented out, and make sure it has

hosts: ["localhost:5044"]

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.