Unable to change default docker user


(Eric) #1

I'm using rancher, and I'm trying to setup a container to read from all the configured log directories on the host filesystem (i.e. /var/log).

However, the default id used by docker.elastic.co/beats/filebeat:6.2.2 is 1000. So, it can't read anything it doesn't have ownership of.

Is there a best practice for this? Should I be using logstash or a shipper instead?


(Carlos PĂ©rez Aradros) #2

Hi @naisanza,

You can run Filebeat as root if needed, you can either update the image to apply correct permissions to configuration files or pass --strict.perms=false parameter

Best regards


(Eric) #3

@exekias I'm using Rancher, so I'm using the official images. I'm guessing those are docker parameters and not parameters I can apply to the entrypoint inside the official image?


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.