Unable to install elastic-logging-plugin (docker plugin) >= 7.13.0 (beatSocket.sock: connect: no such file or directory)


recently I decided to upgrade my stack to 7.15, during upgrade I discover that I can't install latest elastic-logging-plugin (docker plugin), future investigation shows that only following versions works in my case:

  • 7.10.0 - previously used
  • 7.11.0 - 7.12.0 - plugin installed without issue
  • 7.13.0 - 7.15.0 - plugin installed but during installation following error are seen:
# docker plugin install elastic/elastic-logging-plugin:7.13.0
Plugin "elastic/elastic-logging-plugin:7.13.0" is requesting the following privileges:
 - network: [host]
 - mount: [/var/lib/docker]
Do you grant the above permissions? [y/N] y
7.13.0: Pulling from elastic/elastic-logging-plugin
0a7aa83c65e3: Download complete 
Digest: sha256:7a26e25ced11c756725914f608988782eb3d4c3985d523b7cb8b4edf71354ab0
Status: Downloaded newer image for elastic/elastic-logging-plugin:7.13.0
Error response from daemon: dial unix /run/docker/plugins/51a186e1e10e488351c598eb2df82072066de72d44a930ebf0ef2db3dc595f8f/beatSocket.sock: connect: no such file or directory

same error can be seen during attempt of plugin activation (docker plugin enable)

Docker daemon doesn't have any specific extra configuration:

# docker version
Client: Docker Engine - Community
 Version:           19.03.15
 API version:       1.40
 Go version:        go1.13.15
 Git commit:        99e3ed8919
 Built:             Sat Jan 30 03:17:11 2021
 OS/Arch:           linux/amd64
 Experimental:      false

Server: Docker Engine - Community
  Version:          19.03.15
  API version:      1.40 (minimum version 1.12)
  Go version:       go1.13.15
  Git commit:       99e3ed8919
  Built:            Sat Jan 30 03:15:40 2021
  OS/Arch:          linux/amd64
  Experimental:     false
  Version:          1.4.3
  GitCommit:        269548fa27e0089a8b8278fc4fc781d7f65a939b
  Version:          1.0.0-rc92
  GitCommit:        ff819c7e9184c13b7c2607fe6c30ae19403a7aff
  Version:          0.18.0
  GitCommit:        fec3683

# docker info
 Debug Mode: false

 Containers: 2
  Running: 1
  Paused: 0
  Stopped: 1
 Images: 10
 Server Version: 19.03.15
 Storage Driver: overlay2
  Backing Filesystem: extfs
  Supports d_type: true
  Native Overlay Diff: true
 Logging Driver: json-file
 Cgroup Driver: cgroupfs
  Volume: local
  Network: bridge host ipvlan macvlan null overlay
  Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
 Swarm: inactive
 Runtimes: runc
 Default Runtime: runc
 Init Binary: docker-init
 containerd version: 269548fa27e0089a8b8278fc4fc781d7f65a939b
 runc version: ff819c7e9184c13b7c2607fe6c30ae19403a7aff
 init version: fec3683
 Security Options:
   Profile: default
 Kernel Version: 5.9.0-2-cloud-amd64
 Operating System: Debian GNU/Linux 9 (stretch)
 OSType: linux
 Architecture: x86_64
 CPUs: 1
 Total Memory: 983.9MiB
 Name: gw1
 Docker Root Dir: /var/lib/docker
 Debug Mode: false
 Registry: https://index.docker.io/v1/
 Experimental: false
 Insecure Registries:
 Live Restore Enabled: false

same error response can be seen in dockerd log:

beatSocket.sock: connect: no such file or directory

but I do not see any changes in requirements or configuration,
does anyone aware about extra configuration or requirements to get this beatSocket?


I have got the same error, with 7.15.1

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.