Unable to send logs from NON-AWS infrastructure logstash shipper to SQS

I'm trying to implement the logstash to send logs from a NON-AWS infrastructure to SQS through SQS output plugin in shipper conf by passing the "access_key_id" and "secret_access_key", From the logs i'm able to see logstash is able to establish connection to SQS but i don't see any messages in queue. The same configuration used from AWS EC2 in same account works fine.

  • Tried on two different logstash versions 5.5 and 6.2, both had same issue were i could see the connection established but no logs in queue.

  • "access_key_id" and "secret_access_key", Passed in logstash plugin config and credentials file specified by aws_credentials_file.

  • Installed AWS CLI, Able to insert to queue using command line, but failing when running it using logstash.

  • Tested both with and with out proxy.

Shipper Conf:

input {
file {
type =>"app_reporting"
path => ["/apps/opt/log/app_reporting.log"]
sincedb_path =>"/apps/opt/logstash/logstash-5.5.0/var/app_reporting.sincedb"
codec => json
start_position => "beginning"
output {
if [type] =~ "^app_reporting" {
sqs {
access_key_id => ""
secret_access_key => "
queue => "SQS-Queue-Name"
region => "us-east-1"
stdout { codec => rubydebug }

AWS ClI Command (Worked after CLI installation) : aws sqs send-message --queue-url https://sqs.us-east-1.amazonaws.com/*********/SQS-Queue-Name --message-body "Test SQS Message insert"

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.