Update APM indices feeder

Kibana version: 7.5.2

Elasticsearch version: 7.5.2

APM Server version: 7.5.2

APM Agent language and version: Python Flask

Original install method (e.g. download page, yum, deb, from source, etc.) and version: Elastic Cloud

Fresh install or upgraded from other version? It is on an elastic cloud cluster

Is there anything special in your setup? For example, are you using the Logstash or Kafka outputs? Are you using a load balancer in front of the APM Servers? Have you changed index pattern, generated custom templates, changed agent configuration etc. Yes I changed the index pattern and created a new index from the original one (the transaction index, apm-7.5.2-transaction-000001)

Steps to reproduce:

  1. Update the index pattern (apm-*) and add the new mapping and the alias
  2. Create a new index from the one that is fed by the apm agent
  3. The new index will index all the previous data but not the new one.


I am trying to get more data from the metadata information, I created a new index pattern and added the mapping to the field I want, I created the alias for the transaction object (the one I am interested in) and I created a new index from the original one. My problem is the new index is never fed by the new data, and I don't understand where is my mistake, is there any documentation to update the mapping field on the fed index.

I hope it is clear, if not I will try to provide all the information you need to help me.

Thank you.

Hi @bayou,
if I understand you correct then you are running a cloud hosted version of APM Server and try to add additional data to your index template. You took care of setting up the index templates, patterns and indices etc, but the APM Server does not ingest the data to the new indices?
If that's the case, you need to update the configuration for output.elasticsearch.indices to match the indices you want the server to write to. This will automatically disable Index Lifecycle Management (ILM), if you'd like to still leverage Elasticsearch ILM then you would also need to take care of alias and policy setup on your own.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.