Update the registry file

I would like to update delete the old data from the file "registry", in fact I am getting now an error message : no left space on device.
So I would like to delete information about files already parsed by logstash after one hour.

Thanks for help :slight_smile:

Are you sure that the error you are seeing is not due to Filebeat holding onto file descriptors? What's the output of lsof -c filebeat?

I am using an old version of linux, so I am getting lsof bash command not found

In fact when I run filebeat I got a message error that indicates : there is no space left so filebeat can't add new file to registry.new and when I opened registry is stocking data from last week

What's the size of the registry file?
Could you try restarting Filebeat to see if the problem persists?

the size of registry file is 240k it's weird :confused: ! the size of filebeat directory is 48M and the size of my vm is 10Go and there is only filebeat running there. And now the disk is full

Have you tried restarting Filebeat?

Yes, and still getting the same problem

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.