Use filepath instead of inode

I have followed many threads about Filebeat having problems with inode re-use. Many of them end without a solution. We are using Filebeat, and having inode re-use issues as well, even when the filenames are unique. When this happens, Filebeat starts reading a new file at the wrong offset. This results in fields being unaligned. One solution to this is to have an option to use the full filepath and filename as the hashed key into the Filebeat file registry, instead of the inode.

Hi @spacepacket,

For enhancement requests you may better use Github, so we keep track of the status of the feature, and allow other users to watch for updates:

Best regards

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.