Use 'y' for year-of-era. Prefix your date format with '8' to use the new specifier

just to make sure I understood you correctly here and to raise the chances of reproduction? You get this error by just installing Elasticsearch 6.8 without indexing any data into it? Or did you configure some beat or logstash to send data to that fresh 6.8 instance?

--Alex

Vanilla install of elasticsearch. Hence my hesitation to trust the warning, and the confusion/concern.

how is this triggered? Are you indexing data? Are you executing a query? Can you describe the steps until the message occurs? Or really just starting without doing anything?

Install elasticsearch from repo using yum, start elasticsearch, look at deprecation log. Logstash isn't installed anywhere or pointing to the instance. Kibana isn't installed, etc. It's a fresh Linux box without any other configuration regarding elasticsearch. No configurations for elasticsearch have been modified. All default from the repo install. Here's the output if you're curious:

yum install elasticsearch
Loaded plugins: auto-update-debuginfo, fastestmirror
Loading mirror speeds from cached hostfile
 * base: www.gtlib.gatech.edu
 * extras: mirror.pit.teraswitch.com
 * updates: mirrors.tripadvisor.com
elasticsearch-6.x                                                                                                                                              | 1.3 kB  00:00:00
Resolving Dependencies
--> Running transaction check
---> Package elasticsearch.noarch 0:6.8.2-1 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

======================================================================================================================================================================================
 Package                                       Arch                                   Version                                 Repository                                         Size
======================================================================================================================================================================================
Installing:
 elasticsearch                                 noarch                                 6.8.2-1                                 elasticsearch-6.x                                 142 M

Transaction Summary
======================================================================================================================================================================================
Install  1 Package

Total download size: 142 M
Installed size: 227 M
Is this ok [y/d/N]: y
Downloading packages:
elasticsearch-6.8.2.rpm                                                                                                                                        | 142 MB  00:00:26
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Creating elasticsearch group... OK
Creating elasticsearch user... OK
  Installing : elasticsearch-6.8.2-1.noarch                                                                                                                                       1/1
### NOT starting on installation, please execute the following statements to configure elasticsearch service to start automatically using systemd
 sudo systemctl daemon-reload
 sudo systemctl enable elasticsearch.service
### You can start elasticsearch service by executing
 sudo systemctl start elasticsearch.service
Created elasticsearch keystore in /etc/elasticsearch
  Verifying  : elasticsearch-6.8.2-1.noarch                                                                                                                                       1/1

Installed:
  elasticsearch.noarch 0:6.8.2-1

Complete!
> sudo systemctl daemon-reload
> sudo systemctl start elasticsearch.service
> sudo tail /var/log/elasticsearch/elasticsearch_deprecation.log
[2019-08-08T11:45:41,520][WARN ][o.e.d.c.j.Joda           ] [nk3vu6R] 'y' year should be replaced with 'u'. Use 'y' for year-of-era. Prefix your date format with '8' to use the new specifier.

thanks for the description. I think I figured out where this happens (in some xpack code) and will open up a PR!

Drinks on me, wherever we meet :slight_smile:

1 Like

Thank you again. :slightly_smiling_face:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.