[WEIRD] Only some Pipelines in Pipelines.yml stopped working, without making any changes to the conf

Hi, In monday about half of pipelines in my pipelines.yml, stopped working.
I didn make any changes to the single pipelines configurations and to pipelines.yml.
When I run them separately they work, when I run them via logstash service or with the command /usr/share/logstash/bin/logstash --path.settings /etc/logstash they dont.

half of my pipelines are ingesting data from a database with zabbix data. the other half is ingesting data from another zabbix database.

The only diference with the databases is that (the one that is not working) get more data than the other one. could this influence the logstahs behavior?

I changed the location of the postgres JDBC, from a custom location to /usr/share/logstash/logstash-core/lib/jars now is working but erratically, some pipelines doesnt start on schedule, and the quantity of indexed documents is not regular.

I dont know why changing the path of the JDBC make it work again
I dont know why they stopped working
I dont know why some JDBC schedule are are behaving erratically

does someone have any idea?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.