What's the correct value to set setup.dashboards.beat for o365 module?

Hello there!
I'm using ELK and filebeat, both v7.13.0
I enabled o365 module on filebeat configs and enabled setup.dashboards as below

  enabled: true
  index: "azure-*"
  beat: "o365"

  host: "https://kibana.mydomain.foo.bar:443"
  space.id: "azure"
  username: "elastic"
  password: "*******"

The issue was that all dashboards, from all beats were installed, leaving kind of a mess in my space.
In theory, setup.dashboards.beat should select only the proper dashboards/visualizations, but I could find no setting to make it work.

I tried a handful of options as: "O365", "Filebeat-O365-Audit", "O365-Audit", "Filebeat-O365", "o365audit", "Filebeat o365, "o365" with no success.

I know o365 module is still beta, but I thought I should say something.
Also, there could be a list of accepted values on the reference page or the correct way to find them

I think this thread will help you next time: Load one dashboard instead of all Filebeat default dashboards - #2 by pierhugues

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.