Why do not you have the .ps1 extension when decompressing the filebeat package


(Hoa Nguyễn) #1

Hi everybody
I want to install filebeat on Windows server 2012 R2 va windows 10 . But when I extracted the package, I did not have the .ps1 extension so the installation was not successful.
I have tried many times.
Thanks!


(Andrew Kroh) #2

Please try following the installation instructions in the Getting Started Guide. You will use a powershell terminal to run the script.


(Hoa Nguyễn) #3

Hi andrewkroh, Thank you for answering my question.
All I used powershell to install. The steps are as follows:
Step 1 Run powershell as admin
Step 2 Run command: Invoke-WebRequest https://artifacts.elastic.co/downloads/beats/filebeat/filebeat-5.3.2-windows-x86_64.zip -OutFile C:\filebeat-5.3.2-windows-x86_64.zip
Step 3: Expand-Archive -Path C:\filebeat-5.3.2-windows-x86_64.zip -DestinationPath 'C:\Program Files'
Step 4: Rename-Item 'C:\Program Files\filebeat-5.3.2-windows-x86_64' 'C:\Program Files\Filebeat'
Step 5: Remove-Item C:\filebeat-5.3.2-windows-x86_64.zip
Step 6 PowerShell.exe -ExecutionPolicy UnRestricted -File 'C:\Program Files\Filebeat\ filebeat-5.3.2-windows-x86_64\install-service-filebeat.ps1'

at step 6 The system error message does not have an .ps1 extension for installation

:frowning:


(Andrew Kroh) #4

Can you please provide a directory listing (via paste and not a screenshot)? Like...

PS > dir C:\Program Files\Filebeat\filebeat-5.3.2-windows-x86_64\

And can you paste the exact error message you get when running the command in step 6.


(Hoa Nguyễn) #5

I solved my mistake. Thanks for your support. :smiley:
Have a nice day! =)))


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.