Why does logstash not import file into elasticsearch?


(Brook Hutchinson) #1

Versions
Windows 7
elasticsearch v1.6.0
logstash v1.5.2
kibana v4.1.0

Background
I am trying to import an Apache Access Log file into elasticsearch. I am finding that sometimes logstash will work as desired, other times logstash will choke when trying to import the same file.

After an Import Fails...
The DOS Command window returns the following messages
WARNING: exception caught on transport layer ..., closing connection
java.net.SocketException: Permission denied: no further information

If I check the elasticsearch/logs/cluster.log I see the following messages
I see the same error messages.

What I have tried to resolve import issue

  1. stopped elasticsearch/started elasticsearch
  2. changed import file name
  3. changed logstash.conf file name
  4. restarted computer

Question
What is causing the issue? How do I resolve this issue so that logstash will import my Apache Access Log file into elasticsearch every time (instead of only importing the log file into elasticsearch sporadically)?


(system) #2