Windows 7 Logstash JRUBY Error

Hi, I am new to the entire ELK Stack, and I am trying to set up Logstash. I followed all of the instructions (unzipping, setting up config file, starting Logstash). My setup is Windows 7, and my java version is 1.8.0_51.

When I run the following command (pipeline.conf is my config file):
C:\Elastic\logstash-6.2.2\bin>logstash -f pipeline.conf

I am getting the following error:

[ERROR] 2018-03-15 12:30:05.101 [main] Logstash - 
    (LoadError) Could not load FFI Provider: 
    (NotImplementedError) FFI not available: 

Here is what my config file:

    input {
    	stdin {

    #filter {
    #	grok {
    #	}
    #	date {
    #	}

    output {
    	stdout {
    		codec => rubydebug
    	#	hosts => ["localhost:9200"]

Any help would be appreciated. doesn't seem like a valid site. I have tried my exact process on a different machine, and Logstash works. I have been trying to look for a solution for about 2 days now. HELP PLS

Users in similar situation report user permissions issues with temporary directories:

Also possible is that the version of jruby you've got doesn't support the specific hardware architecture on that machine (e.g., processor family).

The issue was being caused by an Enterprise application called AppSense.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.