Winlogbeat can't start the service (Solved)


(suresh) #1

i am getting the following error

PS C:\Program Files\winlogbeat> Start-Service winlogbeat
Start-Service : Service 'winlogbeat (winlogbeat)' cannot be started due to the following error: Cannot start service
winlogbeat on computer '.'.
At line:1 char:1

  • Start-Service winlogbeat
  •   + CategoryInfo          : OpenError: (System.ServiceProcess.ServiceController:ServiceController) [Start-Service],
     ServiceCommandException
      + FullyQualifiedErrorId : CouldNotStartService,Microsoft.PowerShell.Commands.StartServiceCommand
    
    

looks like everything else is working.

can someone help me. thank you


(Andrew Kroh) #2

See this comment: Error: Cannot start service winlogbeat


(suresh) #4

i am running winlogbeat 1.2.3 to logstash 2.2


(suresh) #5

Suggestion [3,General]: The command winlogbeat.exe was not found, but does exist in the current location. Windows PowerS
hell does not load commands from the current location by default. If you trust this command, instead type ".\winlogbeat.
exe". See "get-help about_Command_Precedence" for more details.

when i tryed that it hangs


(suresh) #6

found the solution:

tls:
certificate_authorities: ["C:/ProgramData/winlogbeat/logstash-forwarder.crt"]

when i input the directory path: everything worked.

thank you for your help.


(Andrew Kroh) #7