Workplace Search Cloud > Disable Native login

Hi Everyone,
I've configured saml linked to azure active directory and its working great. I've managed to disable the "login with elastic cloud" option via the deployment config however I can't work out how to disable the "native" realm. e.g. the "username" and "password" prompt. Is there a way to hide / disable this?

Image below

I don't believe there is. This is to avoid you being locked out of Enterprise Search - your Elasticsearch super user credentials (which you hopefully copied/downloaded when you launched your deployment) will always be able to get you access to Enterprise Search.

You can, however, set up role mappings that restrict access to any but Elasticsearch super users.

Hi Matt,

I believe you can hide the native realm in Cloud with the following setting:

ent_search.auth.cloud-native.hidden: true

It sounds like you're already familiar with setting Enterprise Search settings in Cloud, but just in case you need it, this documentation should be helpful: https://www.elastic.co/guide/en/cloud/current/ec-manage-enterprise-search-settings.html

1 Like

@jgr Thanks a heap. Yep that was the setting I was after.