X-pack bricking metricbeat after enabling Central Management

Before i enroll my metricbeat (either windows or linux), i have monitoring.enabled : true under X-pack monitoring, which will allow the beat to show up under Stack Monitoring in Kibana.
But after I enroll that Metricbeat, it get replaced (obviously) back to # monitoring.enabled : false.
I try re-enabling it, but the moment i restart the service it refuses to start

Systemctl Status gives the below

metricbeat.service - Metricbeat is a lightweight shipper for metrics.
Loaded: loaded (/usr/lib/systemd/system/metricbeat.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Tue 2019-10-15 19:16:27 +04; 10s ago
Docs: https://www.elastic.co/products/beats/metricbeat
Process: 21613 ExecStart=/usr/share/metricbeat/bin/metricbeat $BEAT_LOG_OPTS $BEAT_CONFIG_OPTS $BEAT_PATH_OPTS (code=exited, status=1/FAILURE)
Main PID: 21613 (code=exited, status=1/FAILURE)

Oct 15 19:16:27 systemd[1]: metricbeat.service: Service RestartSec=100ms expired, scheduling restart.
Oct 15 19:16:27 systemd[1]: metricbeat.service: Scheduled restart job, restart counter is at 5.
Oct 15 19:16:27 systemd[1]: Stopped Metricbeat is a lightweight shipper for metrics..
Oct 15 19:16:27systemd[1]: metricbeat.service: Start request repeated too quickly.
Oct 15 19:16:27 systemd[1]: metricbeat.service: Failed with result 'exit-code'.
Oct 15 19:16:27 systemd[1]: Failed to start Metricbeat is a lightweight shipper for metrics..

Any idea? It works properly before Central Management.

Update: Apparently once you enable Central Management, you need to reinput the Hosts and User/Pass for it to work.

You would also need to input the below
cluster_name: "name of your cluster"
cluster_uuid: "uuid of your cluster"

You get those by inputting the following in Dev Tools (in the left side bar):

GET /_cluster/state//

So, in the end, it should look something like that:

#============================== Xpack Monitoring ===============================
monitoring.enabled: true
** cluster_name: "elasticsearch"**
** cluster_uuid: "xxxxxxxxxxxxxxxxxxxx"**
** hosts: ["ip.ip.ip.ip:port"]**
** username: your-beat-usr**
** password: a-good-pwd**

Thanks for the help no one ^.^ and you're welcome if you stumble on the same issue.