X509: certificate signed by unknown authority

I'm running Elasticsearch 8 and am trying to output files on a Windows machine to Logstash.

Now in preparation, I'm trying to get the index setup by running the following:

.\filebeat.exe setup --index-management

Which throws an error:

x509: certificate signed by unknown authority.

Now I tried to add the http_ca.crt to the filebeat.yml file in multiple different ways as per some different documentations I found, but to no avail.
Simple question; where in the filebeat.yml file do I need to define what? Elasticsearch generated the http_ca.crt, http.p12 and transport.p12 files upon installation.

I'm aware I could create the index manually by exporting the json, but I really want to get this issue resolved to prevent any further ones. I doubt Filebeat would even be able to output data to Logstash when already it is throwing a certificate error.

When I run this on the host:
curl -v https://debian-elk-log:9200 --user elastic:******** --cacert http_ca.crt

It throws an error:

curl: (7) Failed to connect to debian-elk-log on port 9200: Connection refused

Same error if I use the IP instead.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.