"Your settings are invalid. Setting "" doesnt exist" error during setup

Setting up ELK 8.3.1 on Windows 10 PC and got Elasticsearch and Kabana up and running. Reached to setting up logstash, entered the following command:

.\bin\logstash.bat -e "input { stdin { } } output { stdout {} }"

from the docs Stashing Your First Event | Logstash Reference [8.3] | Elastic
and got the following error:

c:\elasticstack\logstash\bin>logstash.bat -e "input { stdin { } } output { stdout {} }"
"Using bundled JDK: c:\elasticstack\logstash\jdk\bin\java.exe"
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Sending Logstash logs to c:/elasticstack/logstash/logs which is now configured via log4j2.properties
[2022-07-03T10:41:46,249][INFO ][logstash.runner          ] Log4j configuration path used is: c:\elasticstack\logstash\config\log4j2.properties
[2022-07-03T10:41:46,254][INFO ][logstash.runner          ] Starting Logstash {"logstash.version"=>"8.3.1", "jruby.version"=>"jruby 9.2.20.1 (2.5.8) 2021-11-30 2a2962fbd1 OpenJDK 64-Bit Server VM 11.0.15+10 on 11.0.15+10 +indy +jit [mswin32-x86_64]"}
[2022-07-03T10:41:46,255][INFO ][logstash.runner          ] JVM bootstrap flags: [-Xms1g, -Xmx1g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSInitiatingOccupancyOnly, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djruby.compile.invokedynamic=true, -Djruby.jit.threshold=0, -XX:+HeapDumpOnOutOfMemoryError, -Djava.security.egd=file:/dev/urandom, -Dlog4j2.isThreadContextMapInheritable=true, -Djruby.regexp.interruptible=true, -Djdk.io.File.enableADS=true, --add-opens=java.base/java.security=ALL-UNNAMED, --add-opens=java.base/java.io=ALL-UNNAMED, --add-opens=java.base/java.nio.channels=ALL-UNNAMED, --add-opens=java.base/sun.nio.ch=ALL-UNNAMED, --add-opens=java.management/sun.management=ALL-UNNAMED]
Your settings are invalid. Reason: Setting "" doesn't exist. Please check if you haven't made a typo.
[2022-07-03T10:41:46,326][FATAL][org.logstash.Logstash    ] Logstash stopped processing because of an error: (SystemExit) exit
org.jruby.exceptions.SystemExit: (SystemExit) exit
        at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:747) ~[jruby.jar:?]
        at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:710) ~[jruby.jar:?]
        at c_3a_.elasticstack.logstash.lib.bootstrap.environment.<main>(c:\elasticstack\logstash\lib\bootstrap\environment.rb:91) ~[?:?]

It looks like an easy fix. Maybe it can't find some java settings? But I'm new at this.
Appreciate any help.

It's not about the Java settings. The JVM is up and running when this error is logged. Setting --log.level DEBUG might help narrow down what it is doing.

Well, this is extremely weird. Ran the following command:

And it produced a lot of debug info, but kept outputting repetitive debug info. As if logstash was actually running.

So I stopped it with Ctrl+C and ran the command without debug on, and it worked fine. :face_with_spiral_eyes: :astonished:

I don't know what happened but it works now.
Thanks @Badger

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.