_all field getting corrupted, no mapping changes possible anymore

Hi,

with 1.40Beta1 all of a sudden we can not change the mapping on existing
-not all- types in our index anymore.

*mapper [_all] has different store values, *
*mapper [_all] has different store_term_vector values, *
*mapper [_all] has different store_term_vector_offsets values, *
mapper [_all] has different store_term_vector_positions values

This happened with all existing types in the index.

Adding new types and changing the mapping is possible.

Upgrading to 1.40 and restoring a snapshot did not solve this problem.

Setting store* to false results in the same error message, disabling an
enabled _all field is also not possible.

Did this ever happened to somebody else?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/dfc57323-8293-4bcc-9355-10e7a684264b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hmm this is likely due to
https://github.com/elasticsearch/elasticsearch/pull/7377 (fixed in
1.4.0Beta1) which was done to prevent conflicting mapping changes to the
_all field.

What change are you trying to make, that hits this error? Is there a stack
trace?

Mike McCandless

http://blog.mikemccandless.com

On Fri, Nov 7, 2014 at 5:31 AM, mindbits@gmail.com wrote:

Hi,

with 1.40Beta1 all of a sudden we can not change the mapping on existing
-not all- types in our index anymore.

*mapper [_all] has different store values, *
*mapper [_all] has different store_term_vector values, *
*mapper [_all] has different store_term_vector_offsets values, *
mapper [_all] has different store_term_vector_positions values

This happened with all existing types in the index.

Adding new types and changing the mapping is possible.

Upgrading to 1.40 and restoring a snapshot did not solve this problem.

Setting store* to false results in the same error message, disabling an
enabled _all field is also not possible.

Did this ever happened to somebody else?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/dfc57323-8293-4bcc-9355-10e7a684264b%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/dfc57323-8293-4bcc-9355-10e7a684264b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAD7smRcXR_dwYRVNJsQJbJdDL3sQUzF7btW9c8P_MbmM_WLQmQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

thank you for your fast reply.

this actually happened with 1.4.0Beta1 so I am not sure if it's the same
issue.

the mapping was changed by a script and the error not caught with the
mapping value added, the trace of the first occurence is

[DEBUG][action.admin.indices.mapping.put] [Dorma] failed to put mappings on
indices [[INDEX]], type [TYPE]
org.elasticsearch.index.mapper.MergeMappingException: Merge failed with
failures {[mapper [_all] has different store values, mapper [_all] has
different store_term_vector values, mapper [_all] has different
store_term_vector_offsets values, mapper [_all] has different
store_term_vector_positions values]}
at
org.elasticsearch.cluster.metadata.MetaDataMappingService$4.execute(MetaDataMappingService.java:511)
at
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:329)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:153)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:745)

Am Freitag, 7. November 2014 12:12:29 UTC+1 schrieb Michael McCandless:

Hmm this is likely due to
https://github.com/elasticsearch/elasticsearch/pull/7377
https://www.google.com/url?q=https%3A%2F%2Fgithub.com%2Felasticsearch%2Felasticsearch%2Fpull%2F7377&sa=D&sntz=1&usg=AFQjCNEQgpIcl_fREseYc_pd1kEupGv32A
(fixed in 1.4.0Beta1) which was done to prevent conflicting mapping changes
to the _all field.

What change are you trying to make, that hits this error? Is there a
stack trace?

Mike McCandless

http://blog.mikemccandless.com

On Fri, Nov 7, 2014 at 5:31 AM, <mind...@gmail.com <javascript:>> wrote:

Hi,

with 1.40Beta1 all of a sudden we can not change the mapping on existing
-not all- types in our index anymore.

*mapper [_all] has different store values, *
*mapper [_all] has different store_term_vector values, *
*mapper [_all] has different store_term_vector_offsets values, *
mapper [_all] has different store_term_vector_positions values

This happened with all existing types in the index.

Adding new types and changing the mapping is possible.

Upgrading to 1.40 and restoring a snapshot did not solve this problem.

Setting store* to false results in the same error message, disabling an
enabled _all field is also not possible.

Did this ever happened to somebody else?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/dfc57323-8293-4bcc-9355-10e7a684264b%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/dfc57323-8293-4bcc-9355-10e7a684264b%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/37ffa4ad-0762-4c5d-aa94-b9add636f8d0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

On Fri, Nov 7, 2014 at 6:41 AM, mindbits@gmail.com wrote:

thank you for your fast reply.

this actually happened with 1.4.0Beta1 so I am not sure if it's the same
issue.

Sorry, what I mean is that this issue, which adds checking for mapping
conflicts in the _all field and was fixed in 1.4.0Beta1, causes the problem
you're seeing.

the mapping was changed by a script and the error not caught with the

mapping value added, the trace of the first occurence is

[DEBUG][action.admin.indices.mapping.put] [Dorma] failed to put mappings
on indices [[INDEX]], type [TYPE]
org.elasticsearch.index.mapper.MergeMappingException: Merge failed with
failures {[mapper [_all] has different store values, mapper [_all] has
different store_term_vector values, mapper [_all] has different
store_term_vector_offsets values, mapper [_all] has different
store_term_vector_positions values]}
at
org.elasticsearch.cluster.metadata.MetaDataMappingService$4.execute(MetaDataMappingService.java:511)
at
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:329)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:153)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:745)

Hmm, is that script trying to change the mapping for the _all field?

Mike McCandless

http://blog.mikemccandless.com

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAD7smRfYAGaxS4xKfTLoWj0ZhwgzMpzETGTbhvL%3DX9vad4TgqA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

ok, now I understand. seems to be pretty breaking to me and I think that
only a data dump and bulk import will solve it.

thank you very much!

Am Freitag, 7. November 2014 15:04:51 UTC+1 schrieb Michael McCandless:

On Fri, Nov 7, 2014 at 6:41 AM, <mind...@gmail.com <javascript:>> wrote:

thank you for your fast reply.

this actually happened with 1.4.0Beta1 so I am not sure if it's the same
issue.

Sorry, what I mean is that this issue, which adds checking for mapping
conflicts in the _all field and was fixed in 1.4.0Beta1, causes the problem
you're seeing.

the mapping was changed by a script and the error not caught with the

mapping value added, the trace of the first occurence is

[DEBUG][action.admin.indices.mapping.put] [Dorma] failed to put mappings
on indices [[INDEX]], type [TYPE]
org.elasticsearch.index.mapper.MergeMappingException: Merge failed with
failures {[mapper [_all] has different store values, mapper [_all] has
different store_term_vector values, mapper [_all] has different
store_term_vector_offsets values, mapper [_all] has different
store_term_vector_positions values]}
at
org.elasticsearch.cluster.metadata.MetaDataMappingService$4.execute(MetaDataMappingService.java:511)
at
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:329)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:153)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:745)

Hmm, is that script trying to change the mapping for the _all field?

Mike McCandless

http://blog.mikemccandless.com

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/34a2ac13-99cf-4975-9f46-d132db45f010%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.