_all not pulling subfields


(Stefanie) #1

I have a mapping that looks something like this:

"source": {
"properties": {
"description": {
"type": "string",
"index": "not_analyzed",
"omit_norms": true,
"index_options": "docs"
},
"id": {
"type": "string",
"index": "not_analyzed",
"omit_norms": true,
"index_options": "docs"
},
"name": {
"type": "string",
"boost": 3.0,
"analyzer": "snowball"
}
}
}

However when running the following query:

{"query" :
{"match" :
{"_all" : "test phrase"}
}
}

I don't get the results returned from this query:

{"query" :
{"match" :
{"source.name" : "test phrase"}
}
}

How do I get the '_all' query to match on a subfield?

Thank you for any help,
Stefanie

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b04dbe47-2b8a-4493-b867-4691eaee2381%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Alexander Reelsen) #2

Hey,

from my birds eye view this should work. Can you create a fully fledged
example (including index creation, mapping creation, document creation), so
one can replay this. And tell your ES version along, if you have any
special configuration going on.

--Alex

On Thu, Jul 10, 2014 at 8:31 PM, Stefanie stefanie@backstit.ch wrote:

I have a mapping that looks something like this:

"source": {
"properties": {
"description": {
"type": "string",
"index": "not_analyzed",
"omit_norms": true,
"index_options": "docs"
},
"id": {
"type": "string",
"index": "not_analyzed",
"omit_norms": true,
"index_options": "docs"
},
"name": {
"type": "string",
"boost": 3.0,
"analyzer": "snowball"
}
}
}

However when running the following query:

{"query" :
{"match" :
{"_all" : "test phrase"}
}
}

I don't get the results returned from this query:

{"query" :
{"match" :
{"source.name" : "test phrase"}
}
}

How do I get the '_all' query to match on a subfield?

Thank you for any help,
Stefanie

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/b04dbe47-2b8a-4493-b867-4691eaee2381%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/b04dbe47-2b8a-4493-b867-4691eaee2381%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGCwEM9Q8H_KL3KEnMYciC5J-J6YTua-LLwV_QuvWdpM-8%2BwyQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3