_all not working on highlight


(vineeth mohan) #1

Hi ,

I am not able to apply highlight on _all.

Index mapping - https://gist.github.com/2069044
Input JSON and output received - https://gist.github.com/2069060

Thanks
Vineeth


(David Pilato) #2

Yes. You can not highlight _all.
I don't remember why it's not possible.

David :wink:
Twitter : @dadoonet / @elasticsearchfr

Le 18 mars 2012 à 06:07, Vineeth Mohan vineethmohan@algotree.com a écrit :

Hi ,

I am not able to apply highlight on _all.

Index mapping - https://gist.github.com/2069044
Input JSON and output received - https://gist.github.com/2069060

Thanks
Vineeth


(Lukáš Vlček) #3

To find out more about why highlighting does not work on _all by default
and how to make it possible and if it is good practice at all please
check the bottom of this page
http://www.elasticsearch.org/guide/reference/mapping/all-field.html

On Sun, Mar 18, 2012 at 8:54 AM, David Pilato david@pilato.fr wrote:

Yes. You can not highlight _all.
I don't remember why it's not possible.

David :wink:
Twitter : @dadoonet / @elasticsearchfr

Le 18 mars 2012 à 06:07, Vineeth Mohan vineethmohan@algotree.com a
écrit :

Hi ,

I am not able to apply highlight on _all.

Index mapping - https://gist.github.com/2069044
Input JSON and output received - https://gist.github.com/2069060

Thanks
Vineeth


(David Pilato) #4

Thanks Lukas. Very interesting.
I didn't remember it.

In some use case, it could make sense.

David :wink:
Twitter : @dadoonet / @elasticsearchfr

Le 18 mars 2012 à 10:23, Lukáš Vlček lukas.vlcek@gmail.com a écrit :

To find out more about why highlighting does not work on _all by default and how to make it possible and if it is good practice at all please check the bottom of this page http://www.elasticsearch.org/guide/reference/mapping/all-field.html

On Sun, Mar 18, 2012 at 8:54 AM, David Pilato david@pilato.fr wrote:
Yes. You can not highlight _all.
I don't remember why it's not possible.

David :wink:
Twitter : @dadoonet / @elasticsearchfr

Le 18 mars 2012 à 06:07, Vineeth Mohan vineethmohan@algotree.com a écrit :

Hi ,

I am not able to apply highlight on _all.

Index mapping - https://gist.github.com/2069044
Input JSON and output received - https://gist.github.com/2069060

Thanks
Vineeth


(system) #5