_cat api for nodes


(Jettro Coenradie) #1

Hi,
I am trying the _cat api and I have a question about the output for this
request:

curl "http://192.168.1.100:9200/_cat/nodes?h=name,master,role"

The output for this request is:

Laptop-client - -
jc-pi-wit * d
jc-pi-glas m d
jc-pi-red m d

I was expecting a c for the laptop client, this is configured as master:
false and data: false

The help for role gives:
node.role | r,role,dc,nodeRole | d:data node,
c:client node

Thanks, Jettro

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ce682424-dad6-4e3c-8aa8-d465e06f00d8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jettro Coenradie) #2

When specifying node.client: true I do get the c as expected.

Op dinsdag 11 maart 2014 22:23:11 UTC+1 schreef Jettro Coenradie:

Hi,
I am trying the _cat api and I have a question about the output for this
request:

curl "http://192.168.1.100:9200/_cat/nodes?h=name,master,role"

The output for this request is:

Laptop-client - -
jc-pi-wit * d
jc-pi-glas m d
jc-pi-red m d

I was expecting a c for the laptop client, this is configured as master:
false and data: false

The help for role gives:
node.role | r,role,dc,nodeRole | d:data node,
c:client node

Thanks, Jettro

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5e6ecba2-d3b5-4453-9b85-640957e4fe6a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3