[_source] has unsupported parameters


#1

Hi,
I'm getting mapper_parsing_exception: "Failed to parse mapping [default]: Mapping definition for [_source] has unsupported parameters: [compress : true]". I don't even have _source in my mapping. Does someone knows how to fix this?


(Adrien Grand) #2

We would need more information... What is the operation that triggers this error? Are you using templates by any chance?


(Xiaom Zhong) #3

I also get the same problem.
I use this template:
{
"template": "*",
"mappings": {
"default": {
"_all": {"enabled": false},
"_source": {"compress": true},
"date_detection": false
]
}
}
}
Then I post bulk:
POST /_bulk
{"create": { "_index": "test", "_type": "test"}}
{"host": "test.com", "svc": "test_service", "ppt_id": 1000, "ply_id": 1000, "ctg": "inbound", "dtl": "{"name":"test"}", "time": "2016-08-04T11:48:38", "lv": "debug", "u_id": 1000, "lgn": "test", "session_id": "session"}
Then I get the same problem.
The version is: elasticsearch-2.3.3-1.noarch.
Thank you!


#4

just as the error message said: the current version of elasticsearch does not support property "compress" for meta-data field "_source". if you remove this property definition, this error should alse be removed .


(system) #5