0.90.0.RC1 Percolator Bug?

I think this is a bug in the latest build but I'm not sure how to open a
ticket. This is using 0.90.0.RC1. We've been using ES from 0.19.x through
0.20.5 and this worked fine up to this point. Looks like it is broken in
the newest build.

  1. POST http://localhost:9200/_percolator/foo/1
    {
    "source": "foo",
    "query": {
    "term": {
    "foo": "bar"
    }
    }
    }

  2. PUT http://localhost:9200/foo

  3. POST http://localhost:9200/foo/doc/_percolate
    {
    "query": {
    "term": {
    "source": "foo"
    }
    },
    "doc": {
    "foo": "bar"
    }
    }

ES 0.90.0.RC1 returns:

{
error: NullPointerException[null]
status: 500
}

Thanks!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

On Thu, 2013-03-21 at 06:54 -0700, Ben wrote:

I think this is a bug in the latest build but I'm not sure how to open
a ticket. This is using 0.90.0.RC1. We've been using ES from 0.19.x
through 0.20.5 and this worked fine up to this point. Looks like it is
broken in the newest build.

That does look like a bug. You can open an issue here:

ta

clint

  1. POST http://localhost:9200/_percolator/foo/1
    {
    "source": "foo",
    "query": {
    "term": {
    "foo": "bar"
    }
    }
    }

  2. PUT http://localhost:9200/foo

  3. POST http://localhost:9200/foo/doc/_percolate
    {
    "query": {
    "term": {
    "source": "foo"
    }
    },
    "doc": {
    "foo": "bar"
    }
    }

ES 0.90.0.RC1 returns:

{
error: NullPointerException[null]
status: 500
}

Thanks!

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

On Thursday, March 21, 2013 11:55:28 AM UTC-4, Clinton Gormley wrote:

On Thu, 2013-03-21 at 06:54 -0700, Ben wrote:

I think this is a bug in the latest build but I'm not sure how to open
a ticket. This is using 0.90.0.RC1. We've been using ES from 0.19.x
through 0.20.5 and this worked fine up to this point. Looks like it is
broken in the newest build.

That does look like a bug. You can open an issue here:
http://github.com/elasticsearch/elasticsearch/issues

ta

clint

Clint, thanks, I just submitted the bug!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

I just pushed a fix for this.

simon

On Thursday, March 21, 2013 6:08:19 PM UTC+1, Ben wrote:

On Thursday, March 21, 2013 11:55:28 AM UTC-4, Clinton Gormley wrote:

On Thu, 2013-03-21 at 06:54 -0700, Ben wrote:

I think this is a bug in the latest build but I'm not sure how to open
a ticket. This is using 0.90.0.RC1. We've been using ES from 0.19.x
through 0.20.5 and this worked fine up to this point. Looks like it is
broken in the newest build.

That does look like a bug. You can open an issue here:
http://github.com/elasticsearch/elasticsearch/issues

ta

clint

Clint, thanks, I just submitted the bug!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.