1.0.0.RC2 lots of [WARN ][discovery.zen.ping.multicast] [Pixx] failed to read requesting data from ***

Hi,
It seems that the default ./bin elasticsearch are changed to run in the
front instead of the back end, is this true? As of beta2, still seems to
run fine. But when I upgrade to 1.0.0.Rc1, or RC2
when running ./bin elasticsearch, it starts to run in the front, and gives
me lots of warnings like:
[WARN ][discovery.zen.ping.multicast] [Pixx] failed to read requesting data
from /10.93.69.138:54328
java.io.IOException: No transport address mapped to [21623]
at
org.elasticsearch.common.transport.TransportAddressSerializers.addressFromStream(TransportAddressSerializers.java:71)
at
org.elasticsearch.cluster.node.DiscoveryNode.readFrom(DiscoveryNode.java:267)
at
org.elasticsearch.cluster.node.DiscoveryNode.readNode(DiscoveryNode.java:257)
at
org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing$Receiver.run(MulticastZenPing.java:410)
at java.lang.Thread.run(Thread.java:662)

Is this expected?
Thanks,
Chen

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5ca1d17c-1b4a-4f4e-bd8b-fb8b8bd0896b%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hey,

yes, elasticsearch now starts in the foreground by default, please see
http://www.elasticsearch.org/guide/en/elasticsearch/reference/master/breaking-changes.htmlfor
a list of breaking changes compared to 0.90

The other problem might stem from the problem, that you are still using an
old elasticsearch version somewhere (maybe a node client?) or different JVM
versions (but if it worked before, I rather think the first).

Can you check that? Also, you got an IP (10.93.x.y), does that run a valid
elasticsearch instance or just something that tries to connect to your
cluster?

--Alex

On Tue, Feb 4, 2014 at 8:18 AM, Chen Wang chen.apache.solr@gmail.comwrote:

Hi,
It seems that the default ./bin elasticsearch are changed to run in the
front instead of the back end, is this true? As of beta2, still seems to
run fine. But when I upgrade to 1.0.0.Rc1, or RC2
when running ./bin elasticsearch, it starts to run in the front, and gives
me lots of warnings like:
[WARN ][discovery.zen.ping.multicast] [Pixx] failed to read requesting
data from /10.93.69.138:54328
java.io.IOException: No transport address mapped to [21623]
at
org.elasticsearch.common.transport.TransportAddressSerializers.addressFromStream(TransportAddressSerializers.java:71)
at
org.elasticsearch.cluster.node.DiscoveryNode.readFrom(DiscoveryNode.java:267)
at
org.elasticsearch.cluster.node.DiscoveryNode.readNode(DiscoveryNode.java:257)
at
org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing$Receiver.run(MulticastZenPing.java:410)
at java.lang.Thread.run(Thread.java:662)

Is this expected?
Thanks,
Chen

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/5ca1d17c-1b4a-4f4e-bd8b-fb8b8bd0896b%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGCwEM_SHWxjxsOLHdPN_A%3D3EVhRkE8UxQktAkSEAH5qhOd%2BMQ%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.

Alex,
Thanks for your reply.
There are other es instance (0.90.10) running. But I have configured mine
to have a different cluster name. but still it throws "failed to read
requesting data" warnings. Can these warnings be safely ignored?
Thanks,
Chen

On Monday, February 3, 2014 11:47:58 PM UTC-8, Alexander Reelsen wrote:

Hey,

yes, elasticsearch now starts in the foreground by default, please see
http://www.elasticsearch.org/guide/en/elasticsearch/reference/master/breaking-changes.htmlfor a list of breaking changes compared to 0.90

The other problem might stem from the problem, that you are still using an
old elasticsearch version somewhere (maybe a node client?) or different JVM
versions (but if it worked before, I rather think the first).

Can you check that? Also, you got an IP (10.93.x.y), does that run a valid
elasticsearch instance or just something that tries to connect to your
cluster?

--Alex

On Tue, Feb 4, 2014 at 8:18 AM, Chen Wang <chen.apa...@gmail.com<javascript:>

wrote:

Hi,
It seems that the default ./bin elasticsearch are changed to run in the
front instead of the back end, is this true? As of beta2, still seems to
run fine. But when I upgrade to 1.0.0.Rc1, or RC2
when running ./bin elasticsearch, it starts to run in the front, and
gives me lots of warnings like:
[WARN ][discovery.zen.ping.multicast] [Pixx] failed to read requesting
data from /10.93.69.138:54328http://www.google.com/url?q=http%3A%2F%2F10.93.69.138%3A54328&sa=D&sntz=1&usg=AFQjCNFFy0XQT3DnHx0A83FH4cTkHAynXQ
java.io.IOException: No transport address mapped to [21623]
at
org.elasticsearch.common.transport.TransportAddressSerializers.addressFromStream(TransportAddressSerializers.java:71)
at
org.elasticsearch.cluster.node.DiscoveryNode.readFrom(DiscoveryNode.java:267)
at
org.elasticsearch.cluster.node.DiscoveryNode.readNode(DiscoveryNode.java:257)
at
org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing$Receiver.run(MulticastZenPing.java:410)
at java.lang.Thread.run(Thread.java:662)

Is this expected?
Thanks,
Chen

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/5ca1d17c-1b4a-4f4e-bd8b-fb8b8bd0896b%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e6909354-1bb1-4846-9392-fdae5ae1db91%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hi,
i am facing same issue with my elasticsearch cluster 1.4.2.
Although it doesn't create any problem in querying elasticsearch, but i
have concern how to overcome from this warning.

Thanks,
Anas

On Tuesday, February 4, 2014 at 12:48:30 PM UTC+5:30, Chen Wang wrote:

Hi,
It seems that the default ./bin elasticsearch are changed to run in the
front instead of the back end, is this true? As of beta2, still seems to
run fine. But when I upgrade to 1.0.0.Rc1, or RC2
when running ./bin elasticsearch, it starts to run in the front, and gives
me lots of warnings like:
[WARN ][discovery.zen.ping.multicast] [Pixx] failed to read requesting
data from /10.93.69.138:54328
java.io.IOException: No transport address mapped to [21623]
at
org.elasticsearch.common.transport.TransportAddressSerializers.addressFromStream(TransportAddressSerializers.java:71)
at
org.elasticsearch.cluster.node.DiscoveryNode.readFrom(DiscoveryNode.java:267)
at
org.elasticsearch.cluster.node.DiscoveryNode.readNode(DiscoveryNode.java:257)
at
org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing$Receiver.run(MulticastZenPing.java:410)
at java.lang.Thread.run(Thread.java:662)

Is this expected?
Thanks,
Chen

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b6d8458e-a02d-41b2-bbea-53758d59d8a0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.