3 node ES cluster on single vm


I want to setup a 3 node ES cluster on one VM. I tried to install and configure but seeing issues.

I installed ES to two different directories and configured it . But I am seeing error. My elasticsearch.yml file . Can you please help.

Node 1:

cluster.name: elasticsearch
node.name: node-1
path.data: ["/home/ags/Elastic/data","/data/elk/Elastic-7/data"]
path.logs: /data/elk/Elastic-7/logs
path.repo: ["/home/ags/Elastic/backup"]
http.port: 9200
cluster.initial_master_nodes: ["master.node.com"]


cluster.name: elasticsearch
node.name: node-2
path.data: ["/home/ags/Elastic/data1"]
path.logs: /data/elk/Elastic71/logs
path.repo: ["/home/ags/Elastic/backup"]

node.master: false
node.data: true
node.ingest: false
cluster.remote.connect: false

http.port: 9201
cluster.initial_master_nodes: ["master.node.com"]

I am seeing logs in second node.

[2019-05-08T15:28:31,271][WARN ][o.e.c.c.ClusterFormationFailureHelper] [node-2] master not discovered yet: have discovered []; discovery will continue using [,,,,, [::1]:9300, [::1]:9301, [::1]:9302, [::1]:9303, [::1]:9304] from hosts providers and [{node-2}{i_WUVwRBTB-XrtwyKSTtBQ}{sFq4o45ORBu20F5Y_dKZqQ}{}{}{ml.machine_memory=7674531840, xpack.installed=true, ml.max_open_jobs=20}] from last-known cluster state; node term 0, last-accepted version 0 in term 0

I believe you need to configure what is described in this page: https://www.elastic.co/guide/en/elasticsearch/reference/current/discovery-settings.html

1 Like

I tried the same configuration mentioned in the link. But I am seeing this errors in logs.

Which errors now? And could you share the full log please? Properly formatted please with </> icon.

I am unable to add logs here. Can I email you the logs.

You can add your logs on gist.github.com and share the link here.

What are the logs of the other server?

Could you share also the final complete configuration of both nodes?

Hi Dadoonet, I got it working. I added the wrong port in the elasticsearch.yml so it was not able to discover the master node.

Would you mind showing how you got the port right ? I am having the exact same error and I am unable to make node-2 discover the master.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.