5.3.x to 6.x - org.elasticsearch.client.transport.NoNodeAvailableException: None of the configured nodes are available


(Vivek Bairy) #1

We are upgrading elasticsearch from 5.3.1 to 6.4.0.
Tomcat application is not able to connect elastic with https URL even after installing per format of cert in JDK cacerts.

Error while application is trying to connect elastic instance is :

org.elasticsearch.client.transport.NoNodeAvailableException: None of the configured nodes are available: [{#transport#-1}{QM4k_9t4Ql6yJAtyQ0xZUw}{dc1dvavsintap09.es.ad.adp.com}{51.12.67.67:9200}]

##############################################################
bairyv@dc1dvavsscpap22:~> curl --cacert /tmp/ca.cer https://dc1dvavsintap09.es.ad.adp.com:9200 -u elastic

Working fine.

##############################################################
bairyv@dc1dvavsscpap22:~> curl https://dc1dvavsintap09.es.ad.adp.com:9200 -u elastic

Not working

Enter host password for user 'elastic':

curl: (60) SSL certificate problem: unable to get local issuer certificate

More details here: http://curl.haxx.se/docs/sslcerts.html

curl performs SSL certificate verification by default, using a "bundle"

of Certificate Authority (CA) public keys (CA certs). If the default

bundle file isn't adequate, you can specify an alternate file

using the --cacert option.

If this HTTPS server uses a certificate signed by a CA represented in

the bundle, the certificate verification probably failed due to a

problem with the certificate (it might be expired, or the name might

not match the domain name in the URL).

If you'd like to turn off curl's verification of the certificate, use

the -k (or --insecure) option.


(Jay Modi) #2

Port 9200 is not used for the transport client. You should probably be using port 9300 for the transport client in your application.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.