About an exception when running ES-2.4.6-alpine in a docker-compose file


(Alonso) #1

Hi, i have a problem running ES-2.4.6-alpine within a docker container, i just had written the post in Stackoverflow, this is the link.

I have read in this forum all the posts related with my issue, i think none of them are related with my issue, but i hope one of you could help me. I have to use this old version of ES because of spring-data framework. ES latest version is not ready to use with spring-data, last time i have seen.

Basically i am getting this exception:

demo-kafka-elastic_1  | Caused by: org.elasticsearch.client.transport.NoNodeAvailableException: None of the configured nodes are available: [{#transport#-1}{elastic}{172.21.0.6:9300}]

fullstacktrace link

This is my docker-compose.yml, pastebin link

Please help, if i run the same processes in local mode, it works fine, but when i run them with docker-compose, the exception happens. My apologies if this question is not for this forum, i have done the same question in docker forums and they are sending me to this forum.

Alonso


(Alonso) #2

I reply myself, the problem was in my application.properties file with a field named spring.data.elasticsearch.cluster-name=elasticsearch_aironman
that was interfering with

cluster.name

environment variable docker-compose file.

Deleting the line from application.properties did the trick.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.