ActiveMQ River Configuration

I start to configure an ActiveMQ river, i'm already installed the ActiveMQ
plugin but i feel confused about how to make it working, the documentation
was so brief, Actually, i follow exactly the steps of creating a new river
but i don't know what are the following steps to follow?

Note:

1- I have the an ActiveMQ server up and running and i tested it using a
simple JMS app to push a message into a queue.

2- I created a new river using:

curl -XPUT 'localhost:9200/my_index/myindex_river/_meta' -d '{ "type" : "activemq", "activemq" : { "user" : "guest", "pass" : "guest", "brokerUrl" : "failover://tcp://localhost:61616", "sourceType" : "queue", "sourceName" : "elasticsearch", "consumerName" : "activemq_elasticsearch_river_myindex_river", "durable" : false, "filter" : "" }, "index" : { "bulk_size" : 100, "bulk_timeout" : "10ms" } }'

3- After creating the previous river, i could not get it's status using (curl -XGET 'localhost:9200/my_index/_status'), it give me the index status, not the created river.

4- I could not delete it using (curl -XDELETE 'localhost:9200/_river/myindex_river')

Please, any help to get me the right road with ActiveMQ river configuration with the elasticsearch.

Thanks,
Ashraf Sarhan

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You need to create the river in _river "index". Not in "my_index".

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 15 avr. 2013 à 15:53, Ashraf Sarhan ashraf.sarhan@silicon-nile.com a écrit :

I start to configure an ActiveMQ river, i'm already installed the ActiveMQ plugin but i feel confused about how to make it working, the documentation was so brief, Actually, i follow exactly the steps of creating a new river but i don't know what are the following steps to follow?

Note:

1- I have the an ActiveMQ server up and running and i tested it using a simple JMS app to push a message into a queue.

2- I created a new river using:
curl -XPUT 'localhost:9200/my_index/myindex_river/_meta' -d '{
"type" : "activemq",
"activemq" : {
"user" : "guest",
"pass" : "guest",
"brokerUrl" : "failover://tcp://localhost:61616",
"sourceType" : "queue",
"sourceName" : "elasticsearch",
"consumerName" : "activemq_elasticsearch_river_myindex_river",
"durable" : false,
"filter" : ""
},
"index" : {
"bulk_size" : 100,
"bulk_timeout" : "10ms"
}
}'

3- After creating the previous river, i could not get it's status using (curl -XGET 'localhost:9200/my_index/_status'), it give me the index status, not the created river.

4- I could not delete it using (curl -XDELETE 'localhost:9200/_river/myindex_river')

Please, any help to get me the right road with ActiveMQ river configuration with the elasticsearch.

Thanks,
Ashraf Sarhan

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hello, David

Firstly, thanks for your response. :slight_smile:

Actually, I'm just created a river in the _river index but actually, i
could not figure out what i can do after that? Also, Why i could not create
a river in another index ?

Thanks,
Ashraf Sarhan

On Monday, April 15, 2013 4:36:57 PM UTC+2, David Pilato wrote:

You need to create the river in _river "index". Not in "my_index".

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 15 avr. 2013 à 15:53, Ashraf Sarhan <ashraf...@silicon-nile.com<javascript:>>
a écrit :

I start to configure an ActiveMQ river, i'm already installed the ActiveMQ
plugin but i feel confused about how to make it working, the documentation
was so brief, Actually, i follow exactly the steps of creating a new river
but i don't know what are the following steps to follow?

Note:

1- I have the an ActiveMQ server up and running and i tested it using a
simple JMS app to push a message into a queue.

2- I created a new river using:

curl -XPUT 'localhost:9200/my_index/myindex_river/_meta' -d '{ "type" : "activemq", "activemq" : { "user" : "guest", "pass" : "guest", "brokerUrl" : "failover://tcp://localhost:61616", "sourceType" : "queue", "sourceName" : "elasticsearch", "consumerName" : "activemq_elasticsearch_river_myindex_river", "durable" : false, "filter" : "" }, "index" : { "bulk_size" : 100, "bulk_timeout" : "10ms" } }'

3- After creating the previous river, i could not get it's status using (curl -XGET 'localhost:9200/my_index/_status'), it give me the index status, not the created river.

4- I could not delete it using (curl -XDELETE 'localhost:9200/_river/myindex_river')

Please, any help to get me the right road with ActiveMQ river configuration with the elasticsearch.

Thanks,
Ashraf Sarhan

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You must create rivers in _river index.
But, you can ask for rivers to send docs in whatever index you want (default to rivername).

It's not documented for this river.
See https://github.com/dadoonet/fsriver
$ curl -XPUT 'localhost:9200/_river/mynewriver/_meta' -d '{ "type": "fs", "fs": { "name": "My tmp2 dir", "url": "/tmp2", "update_rate": 3600000, "includes": [ ".doc" , ".xls", "*.pdf" ] }, "index": { "index": "mydocs", "type": "doc", "bulk_size": 50 } }'
Look at index.index and index.type

HTH

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 15 avr. 2013 à 17:01, Ashraf Sarhan ashraf.sarhan@silicon-nile.com a écrit :

Hello, David

Firstly, thanks for your response. :slight_smile:

Actually, I'm just created a river in the _river index but actually, i could not figure out what i can do after that? Also, Why i could not create a river in another index ?

Thanks,
Ashraf Sarhan

On Monday, April 15, 2013 4:36:57 PM UTC+2, David Pilato wrote:

You need to create the river in _river "index". Not in "my_index".

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 15 avr. 2013 à 15:53, Ashraf Sarhan ashraf...@silicon-nile.com a écrit :

I start to configure an ActiveMQ river, i'm already installed the ActiveMQ plugin but i feel confused about how to make it working, the documentation was so brief, Actually, i follow exactly the steps of creating a new river but i don't know what are the following steps to follow?

Note:

1- I have the an ActiveMQ server up and running and i tested it using a simple JMS app to push a message into a queue.

2- I created a new river using:
curl -XPUT 'localhost:9200/my_index/myindex_river/_meta' -d '{
"type" : "activemq",
"activemq" : {
"user" : "guest",
"pass" : "guest",
"brokerUrl" : "failover://tcp://localhost:61616",
"sourceType" : "queue",
"sourceName" : "elasticsearch",
"consumerName" : "activemq_elasticsearch_river_myindex_river",
"durable" : false,
"filter" : ""
},
"index" : {
"bulk_size" : 100,
"bulk_timeout" : "10ms"
}
}'

3- After creating the previous river, i could not get it's status using (curl -XGET 'localhost:9200/my_index/_status'), it give me the index status, not the created river.

4- I could not delete it using (curl -XDELETE 'localhost:9200/_river/myindex_river')

Please, any help to get me the right road with ActiveMQ river configuration with the elasticsearch.

Thanks,
Ashraf Sarhan

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Actually, I'm not using a file system data for ES but my data is coming
from the Nutch crawler so i planned to use the ActiveMQ to send the data
from nutch to the ES, i found the ActiveMQ ES plugin to achieve that. While
i'm going with it, i stopped, trying to get the ActiveMQ plugin work. I'm
just need any guide to get that plugin work.

So, Do you think that there is any other solution for my case, David ?

Thanks,
Ashraf Sarhan

On Monday, April 15, 2013 6:02:50 PM UTC+2, David Pilato wrote:

You must create rivers in _river index.
But, you can ask for rivers to send docs in whatever index you want
(default to rivername).

It's not documented for this river.
See https://github.com/dadoonet/fsriver

$ curl -XPUT 'localhost:9200/_river/mynewriver/_meta' -d '{ "type": "fs", "fs": { "name": "My tmp2 dir", "url": "/tmp2", "update_rate": 3600000, "includes": [ ".doc" , ".xls", "*.pdf" ] }, "index": { "index": "mydocs", "type": "doc", "bulk_size": 50 }}'

Look at index.index and index.type

HTH

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 15 avr. 2013 à 17:01, Ashraf Sarhan <ashraf...@silicon-nile.com<javascript:>>
a écrit :

Hello, David

Firstly, thanks for your response. :slight_smile:

Actually, I'm just created a river in the _river index but actually, i
could not figure out what i can do after that? Also, Why i could not create
a river in another index ?

Thanks,
Ashraf Sarhan

On Monday, April 15, 2013 4:36:57 PM UTC+2, David Pilato wrote:

You need to create the river in _river "index". Not in "my_index".

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 15 avr. 2013 à 15:53, Ashraf Sarhan ashraf...@silicon-nile.com a
écrit :

I start to configure an ActiveMQ river, i'm already installed the
ActiveMQ plugin but i feel confused about how to make it working, the
documentation was so brief, Actually, i follow exactly the steps of
creating a new river but i don't know what are the following steps to
follow?

Note:

1- I have the an ActiveMQ server up and running and i tested it using a
simple JMS app to push a message into a queue.

2- I created a new river using:

curl -XPUT 'localhost:9200/my_index/myindex_river/_meta' -d '{ "type" : "activemq", "activemq" : { "user" : "guest", "pass" : "guest", "brokerUrl" : "failover://tcp://localhost:61616", "sourceType" : "queue", "sourceName" : "elasticsearch", "consumerName" : "activemq_elasticsearch_river_myindex_river", "durable" : false, "filter" : "" }, "index" : { "bulk_size" : 100, "bulk_timeout" : "10ms" } }'

3- After creating the previous river, i could not get it's status using (curl -XGET 'localhost:9200/my_index/_status'), it give me the index status, not the created river.

4- I could not delete it using (curl -XDELETE 'localhost:9200/_river/myindex_river')

Please, any help to get me the right road with ActiveMQ river configuration with the elasticsearch.

Thanks,
Ashraf Sarhan

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

I know that you are using ActiveMQ and not FS river.
I was just meaning that you need to define your river under _river index and set in it:
index.index: yourindexname
index.type: yourtype

Just follow the doc: https://github.com/domdorn/elasticsearch-river-activemq/
curl -XPUT 'localhost:9200/_river/name_of_your_river/meta' -d '{ "type" : "activemq", "activemq" : { "user" : "guest", "pass" : "guest", "brokerUrl" : "failover://tcp://localhost:61616", "sourceType" : "queue", "sourceName" : "elasticsearch", "consumerName" : "activemq_elasticsearch_river" + rivername, "durable" : false, "filter" : "" }, "index" : { "bulk_size" : 100, "bulk_timeout" : "10ms" } }'

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 15 avr. 2013 à 18:26, Ashraf Sarhan ashraf.sarhan@silicon-nile.com a écrit :

Actually, I'm not using a file system data for ES but my data is coming from the Nutch crawler so i planned to use the ActiveMQ to send the data from nutch to the ES, i found the ActiveMQ ES plugin to achieve that. While i'm going with it, i stopped, trying to get the ActiveMQ plugin work. I'm just need any guide to get that plugin work.

So, Do you think that there is any other solution for my case, David ?

Thanks,
Ashraf Sarhan

On Monday, April 15, 2013 6:02:50 PM UTC+2, David Pilato wrote:

You must create rivers in _river index.
But, you can ask for rivers to send docs in whatever index you want (default to rivername).

It's not documented for this river.
See https://github.com/dadoonet/fsriver
$ curl -XPUT 'localhost:9200/_river/mynewriver/_meta' -d '{ "type": "fs", "fs": { "name": "My tmp2 dir", "url": "/tmp2", "update_rate": 3600000, "includes": [ ".doc" , ".xls", "*.pdf" ] }, "index": { "index": "mydocs", "type": "doc", "bulk_size": 50 } }'
Look at index.index and index.type

HTH

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 15 avr. 2013 à 17:01, Ashraf Sarhan ashraf...@silicon-nile.com a écrit :

Hello, David

Firstly, thanks for your response. :slight_smile:

Actually, I'm just created a river in the _river index but actually, i could not figure out what i can do after that? Also, Why i could not create a river in another index ?

Thanks,
Ashraf Sarhan

On Monday, April 15, 2013 4:36:57 PM UTC+2, David Pilato wrote:

You need to create the river in _river "index". Not in "my_index".

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 15 avr. 2013 à 15:53, Ashraf Sarhan ashraf...@silicon-nile.com a écrit :

I start to configure an ActiveMQ river, i'm already installed the ActiveMQ plugin but i feel confused about how to make it working, the documentation was so brief, Actually, i follow exactly the steps of creating a new river but i don't know what are the following steps to follow?

Note:

1- I have the an ActiveMQ server up and running and i tested it using a simple JMS app to push a message into a queue.

2- I created a new river using:
curl -XPUT 'localhost:9200/my_index/myindex_river/_meta' -d '{
"type" : "activemq",
"activemq" : {
"user" : "guest",
"pass" : "guest",
"brokerUrl" : "failover://tcp://localhost:61616",
"sourceType" : "queue",
"sourceName" : "elasticsearch",
"consumerName" : "activemq_elasticsearch_river_myindex_river",
"durable" : false,
"filter" : ""
},
"index" : {
"bulk_size" : 100,
"bulk_timeout" : "10ms"
}
}'

3- After creating the previous river, i could not get it's status using (curl -XGET 'localhost:9200/my_index/_status'), it give me the index status, not the created river.

4- I could not delete it using (curl -XDELETE 'localhost:9200/_river/myindex_river')

Please, any help to get me the right road with ActiveMQ river configuration with the elasticsearch.

Thanks,
Ashraf Sarhan

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Actually, I do exactly what did you mention but i did not get any result. I
need more information, please.

On Monday, April 15, 2013 8:03:16 PM UTC+2, David Pilato wrote:

I know that you are using ActiveMQ and not FS river.
I was just meaning that you need to define your river under _river index
and set in it:
index.index: yourindexname
index.type: yourtype

Just follow the doc:
https://github.com/domdorn/elasticsearch-river-activemq/

curl -XPUT 'localhost:9200/_river/name_of_your_river/meta' -d '{ "type" : "activemq", "activemq" : { "user" : "guest", "pass" : "guest", "brokerUrl" : "failover://tcp://localhost:61616", "sourceType" : "queue", "sourceName" : "elasticsearch", "consumerName" : "activemq_elasticsearch_river" + rivername, "durable" : false, "filter" : "" }, "index" : { "bulk_size" : 100, "bulk_timeout" : "10ms" } }'

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 15 avr. 2013 à 18:26, Ashraf Sarhan <ashraf...@silicon-nile.com<javascript:>>
a écrit :

Actually, I'm not using a file system data for ES but my data is coming
from the Nutch crawler so i planned to use the ActiveMQ to send the data
from nutch to the ES, i found the ActiveMQ ES plugin to achieve that. While
i'm going with it, i stopped, trying to get the ActiveMQ plugin work. I'm
just need any guide to get that plugin work.

So, Do you think that there is any other solution for my case, David ?

Thanks,
Ashraf Sarhan

On Monday, April 15, 2013 6:02:50 PM UTC+2, David Pilato wrote:

You must create rivers in _river index.
But, you can ask for rivers to send docs in whatever index you want
(default to rivername).

It's not documented for this river.
See https://github.com/dadoonet/fsriver

$ curl -XPUT 'localhost:9200/_river/mynewriver/_meta' -d '{ "type": "fs", "fs": { "name": "My tmp2 dir", "url": "/tmp2", "update_rate": 3600000, "includes": [ ".doc" , ".xls", "*.pdf" ] }, "index": { "index": "mydocs", "type": "doc", "bulk_size": 50 }}'

Look at index.index and index.type

HTH

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 15 avr. 2013 à 17:01, Ashraf Sarhan ashraf...@silicon-nile.com a
écrit :

Hello, David

Firstly, thanks for your response. :slight_smile:

Actually, I'm just created a river in the _river index but actually, i
could not figure out what i can do after that? Also, Why i could not create
a river in another index ?

Thanks,
Ashraf Sarhan

On Monday, April 15, 2013 4:36:57 PM UTC+2, David Pilato wrote:

You need to create the river in _river "index". Not in "my_index".

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 15 avr. 2013 à 15:53, Ashraf Sarhan ashraf...@silicon-nile.com a
écrit :

I start to configure an ActiveMQ river, i'm already installed the
ActiveMQ plugin but i feel confused about how to make it working, the
documentation was so brief, Actually, i follow exactly the steps of
creating a new river but i don't know what are the following steps to
follow?

Note:

1- I have the an ActiveMQ server up and running and i tested it using a
simple JMS app to push a message into a queue.

2- I created a new river using:

curl -XPUT 'localhost:9200/my_index/myindex_river/_meta' -d '{ "type" : "activemq", "activemq" : { "user" : "guest", "pass" : "guest", "brokerUrl" : "failover://tcp://localhost:61616", "sourceType" : "queue", "sourceName" : "elasticsearch", "consumerName" : "activemq_elasticsearch_river_myindex_river", "durable" : false, "filter" : "" }, "index" : { "bulk_size" : 100, "bulk_timeout" : "10ms" } }'

3- After creating the previous river, i could not get it's status using (curl -XGET 'localhost:9200/my_index/_status'), it give me the index status, not the created river.

4- I could not delete it using (curl -XDELETE 'localhost:9200/_river/myindex_river')

Please, any help to get me the right road with ActiveMQ river configuration with the elasticsearch.

Thanks,
Ashraf Sarhan

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

I answered here: http://stackoverflow.com/questions/16039700/elasticsearch-activemq-river-configuration/16043264#16043264

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 16 avr. 2013 à 15:54, Ashraf Sarhan ashraf.sarhan@silicon-nile.com a écrit :

Actually, I do exactly what did you mention but i did not get any result. I need more information, please.

On Monday, April 15, 2013 8:03:16 PM UTC+2, David Pilato wrote:
I know that you are using ActiveMQ and not FS river.
I was just meaning that you need to define your river under _river index and set in it:
index.index: yourindexname
index.type: yourtype

Just follow the doc: https://github.com/domdorn/elasticsearch-river-activemq/
curl -XPUT 'localhost:9200/_river/name_of_your_river/meta' -d '{ "type" : "activemq", "activemq" : { "user" : "guest", "pass" : "guest", "brokerUrl" : "failover://tcp://localhost:61616", "sourceType" : "queue", "sourceName" : "elasticsearch", "consumerName" : "activemq_elasticsearch_river" + rivername, "durable" : false, "filter" : "" }, "index" : { "bulk_size" : 100, "bulk_timeout" : "10ms" } }'

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 15 avr. 2013 à 18:26, Ashraf Sarhan ashraf...@silicon-nile.com a écrit :

Actually, I'm not using a file system data for ES but my data is coming from the Nutch crawler so i planned to use the ActiveMQ to send the data from nutch to the ES, i found the ActiveMQ ES plugin to achieve that. While i'm going with it, i stopped, trying to get the ActiveMQ plugin work. I'm just need any guide to get that plugin work.

So, Do you think that there is any other solution for my case, David ?

Thanks,
Ashraf Sarhan

On Monday, April 15, 2013 6:02:50 PM UTC+2, David Pilato wrote:
You must create rivers in _river index.
But, you can ask for rivers to send docs in whatever index you want (default to rivername).

It's not documented for this river.
See https://github.com/dadoonet/fsriver
$ curl -XPUT 'localhost:9200/_river/mynewriver/_meta' -d '{ "type": "fs", "fs": { "name": "My tmp2 dir", "url": "/tmp2", "update_rate": 3600000, "includes": [ ".doc" , ".xls", "*.pdf" ] }, "index": { "index": "mydocs", "type": "doc", "bulk_size": 50 } }'
Look at index.index and index.type

HTH

David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 15 avr. 2013 à 17:01, Ashraf Sarhan ashraf...@silicon-nile.com a écrit :

Hello, David

Firstly, thanks for your response. :slight_smile:

Actually, I'm just created a river in the _river index but actually, i could not figure out what i can do after that? Also, Why i could not create a river in another index ?

Thanks,
Ashraf Sarhan

On Monday, April 15, 2013 4:36:57 PM UTC+2, David Pilato wrote:
You need to create the river in _river "index". Not in "my_index".

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 15 avr. 2013 à 15:53, Ashraf Sarhan ashraf...@silicon-nile.com a écrit :

I start to configure an ActiveMQ river, i'm already installed the ActiveMQ plugin but i feel confused about how to make it working, the documentation was so brief, Actually, i follow exactly the steps of creating a new river but i don't know what are the following steps to follow?

Note:

1- I have the an ActiveMQ server up and running and i tested it using a simple JMS app to push a message into a queue.

2- I created a new river using:
curl -XPUT 'localhost:9200/my_index/myindex_river/_meta' -d '{
"type" : "activemq",
"activemq" : {
"user" : "guest",
"pass" : "guest",
"brokerUrl" : "failover://tcp://localhost:61616",
"sourceType" : "queue",
"sourceName" : "elasticsearch",
"consumerName" : "activemq_elasticsearch_river_myindex_river",
"durable" : false,
"filter" : ""
},
"index" : {
"bulk_size" : 100,
"bulk_timeout" : "10ms"
}
}'

3- After creating the previous river, i could not get it's status using (curl -XGET 'localhost:9200/my_index/_status'), it give me the index status, not the created river.

4- I could not delete it using (curl -XDELETE 'localhost:9200/_river/myindex_river')

Please, any help to get me the right road with ActiveMQ river configuration with the elasticsearch.

Thanks,
Ashraf Sarhan

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.