Adding plugin when ElasticSearch is compiled from source


(rastro) #1

I need to make a change to the ES code for my installation. When I
compile, the version is set to 1.0.0.

When I go to install the python plugin, it doesn't like that version id (it
supports up to .90).

   https://github.com/elasticsearch/elasticsearch-lang-python

I guess I need to force the version number back to .90 to make the plugin
happy.

How can I do this, or is there a better way?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

I guess you have to change python plugin as well to be 1.0 compatible, right?
Or wait for a new release of python plugin.

What kind if error do you get?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 30 oct. 2013 à 02:31, rastro robert@webmstr.com a écrit :

I need to make a change to the ES code for my installation. When I compile, the version is set to 1.0.0.

When I go to install the python plugin, it doesn't like that version id (it supports up to .90).

   https://github.com/elasticsearch/elasticsearch-lang-python

I guess I need to force the version number back to .90 to make the plugin happy.

How can I do this, or is there a better way?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(rastro) #3

The guy who set this up is on vacation, so I started from scratch and the
plugin and ES are happy together.

Unfortunately, my script results don't make it back to my query now. The
results show the field as null.

Is my script supposed to return the value on stdout? Just as a raw value,
or json, or ?

"script_fields" : {
"el": {
"script": "single",
"type": "float",
"lang": "python"
}
}

returns:

   "el" : null,

I have the script doing some debug logging, and the value is being
generated properly.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4