After installing logstash-filter-jdbc_streaming,im facing the follwing error when i check logstash configtest


(Jones Thomas) #1

jones@logserver:~$ sudo service logstash configtest
Bundler::GemNotFound: Could not find gem 'logstash-filter-jdbc_streaming (>= 0) java' in any of the gem sources listed in your Gemfile or installed on this machine.
verify_gemfile_dependencies_are_found! at /opt/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/resolver.rb:328
each at org/jruby/RubyArray.java:1613
verify_gemfile_dependencies_are_found! at /opt/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/resolver.rb:307
start at /opt/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/resolver.rb:199
resolve at /opt/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/resolver.rb:182
resolve at /opt/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/definition.rb:192
specs at /opt/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/definition.rb:132
specs_for at /opt/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/definition.rb:177
requested_specs at /opt/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/definition.rb:166
requested_specs at /opt/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/environment.rb:18
setup at /opt/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/runtime.rb:13
setup at /opt/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler.rb:122
setup! at /opt/logstash/lib/bootstrap/bundler.rb:64
(root) at /opt/logstash/lib/bootstrap/environment.rb:65


(Mark Walkom) #2

What version are you on and how did you install it?


(Jones Thomas) #3

this is my version

Ubuntu 14.04.5 LTS (GNU/Linux 3.13.0-77-generic x86_64)

and i installed it with this command

./logstash-plugin install logstash-filter-jdbc_streaming


(Mark Walkom) #4

What version of LS?


(Jones Thomas) #5

logstash 2.3
kibana 4.4
elasticsearch 2.x


(Guy Boertje) #6

Need to check, sorry, is ./logstash-plugin the same file as opt/logstash/bin/logstash-plugin?


(Jones Thomas) #7

yeah exaclty...and dont be sorry :sweat_smile:
thank you


(Guy Boertje) #8

When I installed jdbc_streaming on 2.3.4 I got this error.

Plugin version conflict, aborting
ERROR: Installation Aborted, message: Bundler could not find compatible versions for gem "logstash-core-plugin-api":
  In snapshot (Gemfile.lock):
    logstash-core-plugin-api (= 1.20.0)

jdbc streaming is compatible with 2.4 and 5.x because the plugin API changed at 2.4


(Jones Thomas) #9

Thank you so much @guyboertje


(Jones Thomas) #10

how can i resolve it??
logstash is not running now..even thought i started after few seconds It stops running automatically.


(Guy Boertje) #11

The only way forward is to upgrade to 2.4 or 5.3 if you want to use the jdbc_streaming filter.


(system) #12

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.