Not able to install logstash-core-event-java gem as its giving me error


(Kartikeya Sharma) #1

Hi All,
I am not able to install the logstash-core-event-java gem as it is gining me this error

Bundler::GemNotFound: Could not find gem 'logstash-filter-translate (>= 0) java' in any of the gem sources listed in your Gemfile or installed on this machine.
verify_gemfile_dependencies_are_found! at C:/ELK/logstash/logstash-5.3.1/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/resolver.rb:328
each at org/jruby/RubyArray.java:1613
verify_gemfile_dependencies_are_found! at C:/ELK/logstash/logstash-5.3.1/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/resolver.rb:307
start at C:/ELK/logstash/logstash-5.3.1/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/resolver.rb:199
resolve at C:/ELK/logstash/logstash-5.3.1/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/resolver.rb:182
resolve at C:/ELK/logstash/logstash-5.3.1/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/definition.rb:192
specs at C:/ELK/logstash/logstash-5.3.1/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/definition.rb:132
specs_for at C:/ELK/logstash/logstash-5.3.1/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/definition.rb:177
requested_specs at C:/ELK/logstash/logstash-5.3.1/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/definition.rb:166
requested_specs at C:/ELK/logstash/logstash-5.3.1/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/environment.rb:18
setup at C:/ELK/logstash/logstash-5.3.1/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/runtime.rb:13
setup at C:/ELK/logstash/logstash-5.3.1/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler.rb:122
setup! at C:/ELK/logstash/logstash-5.3.1/lib/bootstrap/bundler.rb:64
(root) at C:\ELK\logstash\logstash-5.3.1\lib\bootstrap\environment.rb:67

And when i tried to install the logstash-plugin install logstash-filter-translate

its giving me this error

Error Bundler::InstallError, retrying 1/10
An error occurred while installing logstash-core-event-java (5.3.1), and Bundler cannot continue.
Make sure that gem install logstash-core-event-java -v '5.3.1' succeeds before bundling.
WARNING: SSLSocket#session= is not supported


(Guy Boertje) #2

How did you install Logstash v5.3.1?

This is a very unusual error - does the machine you are trying this on have access to the internet?
Can you ping rubygems.org?


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.