Almost 90-100% CPU usage while doing nothing

Hi all,

I came across a issue today in a 2 node cluster where both nodes were
occupying around 100% CPU usage for no reason. No indexing is happening and
no search queries are being executed.

Hot threads output also says the same way. http://pb.abhijeetr.com/TbZi

Stracing the ES process gives: (futex call)

$sudo strace -p 3003
Process 3003 attached - interrupt to quit
futex(0x7f3696d879d0, FUTEX_WAIT, 3005, NULL

^C <unfinished ...>
Process 3003 detached

When I used "perf top" to identify, I see libjvm.so occupying 90% CPU
usage. I'm using elasticsearch-0.90.0-1.noarch version. Any idea what might
be happening?

--
Regards,
Abhijeet Rastogi (shadyabhi)

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

What version of Java? If you are using OpenJDK, switch to the official
Oracle Java 7 as there are all sorts of issues with OpenJDK.

Thanks,
Matt Weber

On Tue, Jun 4, 2013 at 9:14 AM, Abhijeet Rastogi abhijeet.1989@gmail.comwrote:

Hi all,

I came across a issue today in a 2 node cluster where both nodes were
occupying around 100% CPU usage for no reason. No indexing is happening and
no search queries are being executed.

Hot threads output also says the same way. http://pb.abhijeetr.com/TbZi

Stracing the ES process gives: (futex call)

$sudo strace -p 3003
Process 3003 attached - interrupt to quit
futex(0x7f3696d879d0, FUTEX_WAIT, 3005, NULL

^C <unfinished ...>
Process 3003 detached

When I used "perf top" to identify, I see libjvm.so occupying 90% CPU
usage. I'm using elasticsearch-0.90.0-1.noarch version. Any idea what might
be happening?

--
Regards,
Abhijeet Rastogi (shadyabhi)
http://blog.abhijeetr.com

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hi Matt,

Thanks for your reply. Sorry, I forgot to mention the java version. And
yes, I'm using java-1.7.0-openjdk-1.7.0.19-2.3.9.1.el6_4.x86_64.

I'll move to oracle Java 7 now but I'm not sure if that's the problem
because this thing happens only rarely. (Last time it happened a month
ago). Any other thing that might be going wrong here or a known bug or
something?

On Tue, Jun 4, 2013 at 9:49 PM, Matt Weber matt.weber@gmail.com wrote:

What version of Java? If you are using OpenJDK, switch to the official
Oracle Java 7 as there are all sorts of issues with OpenJDK.

Thanks,
Matt Weber

On Tue, Jun 4, 2013 at 9:14 AM, Abhijeet Rastogi abhijeet.1989@gmail.comwrote:

Hi all,

I came across a issue today in a 2 node cluster where both nodes were
occupying around 100% CPU usage for no reason. No indexing is happening and
no search queries are being executed.

Hot threads output also says the same way. http://pb.abhijeetr.com/TbZi

Stracing the ES process gives: (futex call)

$sudo strace -p 3003
Process 3003 attached - interrupt to quit
futex(0x7f3696d879d0, FUTEX_WAIT, 3005, NULL

^C <unfinished ...>
Process 3003 detached

When I used "perf top" to identify, I see libjvm.so occupying 90% CPU
usage. I'm using elasticsearch-0.90.0-1.noarch version. Any idea what might
be happening?

--
Regards,
Abhijeet Rastogi (shadyabhi)
http://blog.abhijeetr.com

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Regards,
Abhijeet Rastogi (shadyabhi)

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.