Always get max results using search from browser

We recently began using browsers to make Elastic Search searches. No matter what I enter into the browser for a
_search "search string" I receive ALL records as a result. Am I formatting my searches incorrectly or what seems to be the problem? Following are some queries I've submitted that have returned ALL records back. Logistics Agency

This query returned ONLY the asked for id:

Can anyone tell me what's wrong?


Dave K

do you have sense installed somewhere? (I use Google Sense plugin for Chrome. also a plugin for Kibana)

Put into server field.

now get indices just to be sure your connected correct. Run this command
/GET /_cat/indices?v=pretty

Paste one of your queries into the sense panel. (it will remove the url part that needs to go into the top Server field)

run query and see what returns.

Let us know what happened.

Hi @dkarnecki,

For a more convenient alternative, you should consider Console which allows you to use the query DSL.

When you use URI search, you have to provide your query using the q request parameter.

Cannot work, q is missing.

You should quote the parameter value, i.e.:"Defense Logistics Agency"

Looks ok to me.

See the reference docs for more examples.


Also noticed the
should be like

look closely at the format of strings they are not correct.

Just saw Daniels post after I posted this.