"An internal server error occurred" when looking at Uptime monitors

I have the latest version of elastic cloud deployment (v7.15.0).

I have 3 instances of heartbeat v7.15.0 running on 3 separate machines pinging same websites and all are sending to same index. Their heartbeat.yml files are identical.

I'm receiving data from heartbeat and can discover and can create visualizations/dashboards with that data. But when I go to Observability > Uptime > Monitors I'm greeted with "An internal server error occurred" message!

I tried

  • Stopping all HB instances
  • Deleting the Index
  • Confirming that the Uptime page shows warning about Index being empty
  • Starting only one HB instance

But the Uptime page stills shows the error.

1 Like

We're currently working on a way to prevent this from happening, but for now you can correct it by following the instructions here.

Apologies for the inconvenience!

Hi Andrew, thank you for the reply.

Unfortunately, the proposed correction did not help.

I did all the steps (ran heartbeat setup and everything) but I'm still getting the error message.

I guess I'll wait for the next version (I'm currently on v7.15.0)

Is there a place where I can track the progress of this?

@Tadija can you please try setting this session variable when you open uptime app
you will have to open browser dev tools

sessionStorage.setItem('uptime_debug', true)

after this hit refresh and you will see the queries uptime uses in the kibana log.

copy/paste few of those queries and try running those in the kibana dev tools.

and see if it returns any data.

Regards

@Tadija to be clear, we haven't started work on the fix. I would like to see it in 7.16.0, but that may not happen.

This issue should be fixable by following those steps. If it didn't work the likely cause was that you did not shut down all heartbeats before deleting indices and aliases. If one heartbeat is running it will mess up the mappings again.

@shahzad31 I've set the uptime_debug=true via chrome dev tools, but I'm not sure where can I see uptime queries.

@Andrew_Cholakian1 is there a way for me to set the require_alias=true setting mentioned here: [libbeat] ILM writes should use `require_alias=true` · Issue #27874 · elastic/beats · GitHub ?

Also, I've removed the solution mark since proposed steps did not fix the issue. I would be happy with some workaround. I followed the linked steps a couple of times, unfortunately the y do not help.