An unexpected error occurred! {:error=>#<ArgumentError: Setting "localhostck.monitoring.elasticsearch.username" hasn't been registered>,


(shaonbean) #1

env: elastic stack 6.1.1 centos6.9

when install x-pack,start logstash erros

[2018-01-12T15:31:58,463][INFO ][logstash.modules.scaffold] Initializing module {:module_name=>"netflow", :directory=>"/usr/share/logstash/modules/netflow/configuration"}
[2018-01-12T15:31:58,466][INFO ][logstash.modules.scaffold] Initializing module {:module_name=>"fb_apache", :directory=>"/usr/share/logstash/modules/fb_apache/configuration"}
[2018-01-12T15:31:58,649][INFO ][logstash.modules.scaffold] Initializing module {:module_name=>"arcsight", :directory=>"/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/x-pack-6.1.1-java/modules/arcsight/configuration"}
[2018-01-12T15:31:58,666][FATAL][logstash.runner ] An unexpected error occurred! {:error=>#<ArgumentError: Setting "localhostck.monitoring.elasticsearch.username" hasn't been registered>, :backtrace=>["/usr/share/logstash/logstash-core/lib/logstash/settings.rb:32:in get_setting'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:65:inset_value'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:84:in block in merge'", "org/jruby/RubyHash.java:1343:ineach'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:84:in merge'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:133:invalidate_all'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:259:in execute'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/command.rb:67:inrun'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:214:in run'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/command.rb:132:inrun'", "/usr/share/logstash/lib/bootstrap/environment.rb:67:in `'"]}


(Magnus B├Ąck) #2

It looks like you have a typo in your configuration file. Find the file containing "localhostck" and post the surrounding lines. Format as preformatted text with the </> toolbar button.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.