Setting "xpack.monitoring.elasticsearch.url" hasn't been registered


(Roflmao) #1

Running docker.elastic.co/logstash/logstash-oss:6.4.0

The settings are set, though logstash crashes with the following:

2018/10/17 08:21:42 Setting 'path.config' from environment.
2018/10/17 08:21:42 Setting 'queue.max_bytes' from environment.
2018/10/17 08:21:42 Setting 'queue.drain' from environment.
2018/10/17 08:21:42 Setting 'http.port' from environment.
2018/10/17 08:21:42 Setting 'http.host' from environment.
2018/10/17 08:21:42 Setting 'path.data' from environment.
2018/10/17 08:21:42 Setting 'queue.checkpoint.writes' from environment.
2018/10/17 08:21:42 Setting 'xpack.monitoring.enabled' from environment.
2018/10/17 08:21:42 Setting 'queue.type' from environment.
2018/10/17 08:21:42 Setting 'config.reload.automatic' from environment.
2018/10/17 08:21:42 Setting 'xpack.monitoring.elasticsearch.url' from environment.
Sending Logstash logs to /usr/share/logstash/logs which is now configured via log4j2.properties
[2018-10-17T08:22:11,878][FATAL][logstash.runner          ] An unexpected error occurred! {:error=>#<ArgumentError: Setting "xpack.monitoring.elasticsearch.url" hasn't been registered>, :backtrace=>["/usr/share/logstash/logstash-core/lib/logstash/settings.rb:36:in `get_setting'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:69:in `set_value'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:88:in `block in merge'", "org/jruby/RubyHash.java:1343:in `each'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:88:in `merge'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:137:in `validate_all'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:278:in `execute'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/command.rb:67:in `run'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:237:in `run'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/command.rb:132:in `run'", "/usr/share/logstash/lib/bootstrap/environment.rb:73:in `<main>'"]}
[2018-10-17T08:22:11,899][ERROR][org.logstash.Logstash    ] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit

logstash.yml:

config.reload.automatic: true
http.host: 0.0.0.0
http.port: 9600
path.config: /usr/share/logstash/pipeline
path.data: /usr/share/logstash/data
queue.checkpoint.writes: 1
queue.drain: true
queue.max_bytes: 1gb
queue.type: persisted
xpack.monitoring.elasticsearch.url: http://es-app.app-logging.svc.kube.XXXX.xxx:9200
xpack.monitoring.enabled: true

(Roflmao) #2

I would say running -oss version doesnt make xpack enabled :wink:


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.