Ansible ECE install

I'm trying to use the Anisble install role following this:


and this:

I've made up an inventory file for a small 1AZ hot/warm deployment. My plan is to setup up to a full 3AZ, but I'm having trouble getting this small version working. I installed the role via ansible-galaxy as in the blog post. Every time I run the playbook I set up to call the "ansible-elastic-cloud-enterprise" role it throws a syntax error in one of the elastic produced yml files as follows:

ERROR! no action detected in task. This often indicates a misspelled module name, or incorrect module path.

The error appears to have been in '/etc/ansible/roles/ansible-elastic-cloud-enterprise/tasks/direct-install/main.yml': line 5, column 3, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

  • name: Reboot the machine with all defaults
    ^ here

The error repeats its self several times in the output. I tried using the --skip-tags base, destructive to reduce the amount of tasks and I get the same error. I know its not getting to the part where it attempts a connection to the hosts in the inventory since I had an error in there and was getting the same error message. I fixed the error in my inventory and ran a simple playbook I wrote aginst it that connects to each ECE host, creates a file, and writes host variables from the inventory file to the newly created file. That runs just fine. I don't know why the direct-install/main.ym is throwing a syntax error. Any ideas? I'm calling it in my playbook like so:

---
- hosts: primary
  gather_facts: true
  roles:
    - ansible-elastic-cloud-enterprise
  vars:
    ece_primary: true

That's just an example of just the primary. I also have hot/warm/master hosts after that. Ideas?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.